günstigste Tankstelle ermitteln

Bild

Betrifft: günstigste Tankstelle ermitteln
von: Christian
Geschrieben am: 29.10.2015 21:06:45

Hallo an alle, ich würde euch bitten mir zu helfen.
Zuerst ich benutze Excel 2016, kann man hier leider nicht auswählen.
Ich suche nach einer Möglichkeit, die Tankpreise von clever-tanken.de (Abfrage hab ich mir in der Bsp Tabelle gespart) zu nehmen, daraus bei vorgegebener Tankmenge zu berechnen, welche Tankstelle die Günstigste ist. Hierbei addiere ich zu dem reinen Tankpreis noch das Geld dazu, was ich benötige um das Benzin für den Weg zur Tankstelle und nach Hause bezahlen.
Die Spalten I, J und K dienen nur der Veranschaulichung, in der Originaltabelle rechne ich nur mit den Spalten G, H und L.
Jetzt zu meinem Problem, ich würde gerne noch eine Berechnung hinzufügen.
Ich würde gerne in B6 einen Preis vorgeben, für den ich tanken möchte. Ich suche nun eine Formel, die ausgibt, bei welcher Tankstelle unter Berücksichtung der Entfernung am meisten Benzin übrig bleibt, wenn ich für den vorgegebenen Preis tanke.
Fällt da jemand eine Formel ein? ich stehe irgendwie auf dem Schlauch.
Danke und Gruß
Christian
https://www.herber.de/bbs/user/101127.xlsx
zur Info, bei der Abfrage waren die letzten 3 Tankstellen der Liste geschlossen, daher der Preis von 0, da die Formel in der Originaltabelle bei Shell Tankstellen 1 ct. abzieht steht in H26 -0,01.

Bild

Betrifft: AW: günstigste Tankstelle ermitteln
von: Sepp
Geschrieben am: 29.10.2015 21:43:00
Hallo Christian,
so?
Tabelle1

 AB
6Betrag50
7Menge47,88

Formeln der Tabelle
ZelleFormel
B7{=MAX(WENN(J2:J28>0;(B6-J2:J28)/H2:H28))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Sepp


Bild

Betrifft: AW: günstigste Tankstelle ermitteln
von: Christian
Geschrieben am: 30.10.2015 08:00:39
Hallo Sepp,
erstmal danke für deine Hilfe,
jein das Ergebnis ist zwar korrekt, aber der Weg dahin ist nicht das was ich mir vorgestellt habe.
Ich sehe jetzt auf deinem Weg keine Möglichkeit mir die Adresse der besagten Tankstelle ausgeben zu lassen, wie ich es in B5 getan habe.
Mir wäre eine Spalte M, die die Tankmenge für jede einzelne Tankstelle ausgibt lieber, sodass ich B6 und B7 auf Spalte M beziehen kann.
Außerdem lässt sich diese Spalte M dann auch ohne Spalte J berechnen, sowie ichs auch mit Spalte L gemacht hab? Hatte ja bereits geschrieben dass es Spalte J im Original nicht gibt.
Gruß und danke
Christian

Bild

Betrifft: AW: günstigste Tankstelle ermitteln
von: Sandro
Geschrieben am: 30.10.2015 08:07:28
Hallo Christian,
wenn ich dich richtig verstehe musst du ja nur ausrechnen, wie viel Liter du für den vorgegebenen Betrag bekommst (max. 35l)und wieviel Sprit du für die Rückfahrt verbrauchst. Das müsste mit folgender Formel funktionieren:
=MIN($B$6/H2;$B$3)-$B$2/100*G2

Bild

Betrifft: AW: günstigste Tankstelle ermitteln
von: Christian
Geschrieben am: 30.10.2015 09:31:59
Hallo Sandro,
danke erstmal auvh für deine Hilfe, ich sage mal fast. Wie gesagt wenn eine Tankstelle geschlossen hat steht als Preis 0 da und damit würde deine Formel in dem Fall eine Division durch 0 ergeben.
Aber

=WENN(H2>0;MIN($B$6/H2;$B$3)-$B$2/100*G2;"")

hab ich dann auch selbst hinbekommen, die Formeln
=MAX(J1:J28) und
=INDEX(E2:E28;VERGLEICH(B7;J2:J28;0))
natürlich auch.
Danke.
Aber eine Frage hätte ich dann aus Neugierde dann doch noch, mit welcher Formel hätte ich denn die Adresse der Tankstelle ausgeben können wenn ich nur Boskos erste Formel gehabt hätte also nicht deine Hilfsspalte?
Gruß
Christian

Bild

Betrifft: AW: günstigste Tankstelle ermitteln
von: Christian
Geschrieben am: 30.10.2015 09:47:27
Hallo Sandro,
mir ist doch noch ein kleines Problem bei deiner Formel aufgefallen,
sie funktioniert nicht mehr, wenn die Tankmenge größer B3 ist.
Benutze stattdessen dann


=WENN(H2>0;($B$6/H2)-$B$2/100*G2;"")

Gruß
Christian

 Bild

Beiträge aus den Excel-Beispielen zum Thema "günstigste Tankstelle ermitteln"