Zeilen Dividieren

Bild

Betrifft: Zeilen Dividieren
von: Chris
Geschrieben am: 29.10.2015 20:17:28

Hallo,
in einer Spalte A befinden sich mehrere Zahlen, aber auch leere Zellen.
In einer Spalte B sind mehrere Quotienten für die Zahlen aus Splate A.
In Spalte C möchte ich gerne das Ergebnis aus der Division haben.
Geht das mit Verweis oder so?
Kann mir da jemand bitte helfen?
Grüße
Chris
https://www.herber.de/bbs/user/101125.xlsm

Bild

Betrifft: AW: Zeilen Dividieren
von: Chris
Geschrieben am: 29.10.2015 20:19:15
Userbild

Bild

Betrifft: AW: noch nicht eindeutig ...
von: ... neopa C
Geschrieben am: 30.10.2015 08:15:14
Hallo Chris,
... was hat das Bild mit Spalte A, B und C? Meinst Du damit Spalte E, J und Q? Und wann genau soll was und wie in Spalte T (oder nicht?) ermittelt werden?
Gruß Werner
.. , - ...

Bild

Betrifft: AW: noch nicht eindeutig ...
von: Chris
Geschrieben am: 30.10.2015 14:20:42
Hallo Werner,
ich bins mal wieder. Mir fällt es schwer so etwas auszudrücken.Du kennst die Tabelle ja bereits.

=WENN((D7>1)*(D6=1); INDEX(B8:B180;VERGLEICH(1;D8:D1998;))-C6;"")
geteilt durch =C7-O7, WENN er positiv ist
und das soll dann in Spalte Q erscheinen, also neben Spalte P
Userbild

Bild

Betrifft: AW: Fragen über Fragen ...
von: ... neopa C
Geschrieben am: 30.10.2015 14:50:51
Hallo Chris,
... und zwar:
1.) Du schreibst: "... und das soll dann in Spalte Q erscheinen, also neben Spalte P"
In Q hast Du aber schon eine Formel zu stehen. Dies soll für eine bestimmten Bedingungen abgeändert werden? Oder?
2.) die Bedingung ist: "...WENN er positiv ist"? und darin meinst Du mit "...er..." wohl _ das Ergebnis der Formel


=WENN((D7>1)*(D6=1); INDEX(B8:B180;VERGLEICH(1;D8:D1998;))-C6;"") 
in Spalte E? oder?
3.) Weiter schreibst Du: "... geteilt durch =C7-O7" Doch in Spalte O ist nirgends ein Wert, also nur durch den Wert in Spalte C teilen? Oder?
4.) Du schreibst im Bild ganz unten aber auch: "Diesen Wert durch Risk Wert teilen, wenn er positiv ist" Der Risk-Wert steht jedoch in Spalte Q. Dies soll aber die Ergebnisspalte sein. Dies geht nicht, wenn es sich um die gleiche Zeile handelt.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Fragen über Fragen ...
von: Chris
Geschrieben am: 30.10.2015 15:06:17
Ok, also ich versuchs noch mal. Der positive Wert aus der Formel
=WENN((D7>1)*(D6=1); INDEX(B8:B180;VERGLEICH(1;D8:D1998;))-C6;"")
in Spalte Points, soll durch den Wert geteilt werden, der sich aus der Formel
=C7-O7
ergibt. Die Werte aus =C7-O7 stehen unter Risk. Die negativen Werte aus
=WENN((D7>1)*(D6=1); INDEX(B8:B180;VERGLEICH(1;D8:D1998;))-C6;"")
sollen ignoriert werden. Das Ergebnis soll in Spalte Q erscheinen.
Ich habe es so Probiert:
((=WENN((D7>1)*(D6=1); INDEX(B8:B180;VERGLEICH(1;D8:D1998;))-C6;""))/=C7-O7)
funtkioniert aber nicht.

Bild

Betrifft: AW: Fragen über Fragen ...
von: Chris
Geschrieben am: 30.10.2015 15:07:21
Hier noch mal die Tabelle,
https://www.herber.de/bbs/user/101139.xlsm

Bild

Betrifft: AW: nun hast Du die Tabelle korrigiert, aber ...
von: ... neopa C
Geschrieben am: 30.10.2015 15:23:36
Hallo Chris,
... offensichtlich nicht gesehen, dass über all da wo sich in sich Spalte E ein positiver Wert ergab, in gleicher Zeile in Spalte P ein Wert 0 steht. Somit kannst Du für keinen Datensatz in Spalte Q einen Wert!
erhalten.

Die Formel in Q7:


=WENNFEHLER((E7>0)*E7/P7;"")
nach unten kopiert belegt diese Aussage.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Du musst eine andere Tabelle haben ...
von: ... neopa C
Geschrieben am: 30.10.2015 15:12:41
Hallo Chris,
... nochmal: in Spalte O Deiner Tabelle1 steht kein Wert und in der Spalte "Risk" (Spalte Q) steht auch eine andere Formel und zwar: in Q7: =WENN(C7<>0;C7-P7;"0")
Die Werte der Spalte Q können auch nicht genutzt werden (jedenfalls nicht mit einer Formel), wenn das neue Gesamtergebnis wieder in Spalte Q geschrieben werden soll.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Du musst eine andere Tabelle haben ...
von: Chris
Geschrieben am: 30.10.2015 15:18:02
Hier die aktuelle Tabelle. Das ist die Tabelle auf die ich mich beziehe. Entschuldigung für die Verwirrung.
https://www.herber.de/bbs/user/101140.xlsm

Bild

Betrifft: AW: dazu siehe ...
von: ... neopa C
Geschrieben am: 02.11.2015 09:06:05
Hallo Chris,
... mein Beitrag vom Freitagnachmittag weiter oben, hier: https://www.herber.de/forum/archiv/1452to1456/t1455309.htm#1455470. Die dortige Aussage lautete: "... offensichtlich hast Du nicht gesehen, dass überall da wo sich in sich Spalte E ein positiver Wert ergibt, in gleicher Zeile in Spalte P ein Wert 0 steht. Somit kannst Du für keinen Datensatz in Spalte Q einen Werterhalten."

Gruß Werner
.. , - ...

Bild

Betrifft: AW: dazu siehe ...
von: Chris
Geschrieben am: 03.11.2015 19:29:52
Hallo Werner,
ich bin krank, konnte desahlb erst heute antworten. Der Wert in Spalte E soll durch den Wert in Spalte P geteilt werden, aber genau ein Wert über der 0 in Spalte Risk.
Zum Beispiel: Wert E31 soll durch Wert P30 geteilt werden, aber nur wenn Wert E31 positiv ist.
Grüße
Chris

Bild

Betrifft: AW: nachgefragt ...und ...
von: ... neopa C
Geschrieben am: 04.11.2015 09:45:32
Hallo Chris,
... es soll also immer als Teiler der Wert aus Spalte P genommen werden, der eine Zeile über dem positiven Wert der Spalte E liegt?. Dann in Q7 folgende Formel:


=WENN((E7>0)*(E7<>"");E7/P6;"")
und diese ziehend nach unten kopieren.
Wünsche nun noch gute Genesung.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: nachgefragt ...und ...
von: Chris
Geschrieben am: 04.11.2015 15:21:00
Danke das funtioniert! Ich muss noch an meiner Ausdruckweise üben, werd nicht das letzte mal hier gewesen sein.
1.Sag mal was bedeutet (E7<>"")? E7 ungleich?
2.Warum wird hier multipliziert (E7>0)*(E7<>"")?
3.Am Ende der Formel noch mal das Zeichen ""?
dann verstehe ich auch dei Zusammenhänge besser.
Grüße und Dank an Werner

Bild

Betrifft: AW: nachgefragt ...und ...
von: Chris
Geschrieben am: 04.11.2015 15:51:34
Danke das funtioniert! Ich muss noch an meiner Ausdruckweise üben, werd nicht das letzte mal hier gewesen sein.
1.Sag mal was bedeutet (E7<>"")? E7 ungleich?
2.Warum wird hier multipliziert (E7>0)*(E7<>"")?
3.Am Ende der Formel noch mal das Zeichen ""?
dann verstehe ich auch dei Zusammenhänge besser.
Grüße und Dank an Werner

Bild

Betrifft: AW: zu Deinen zusätzlichen Fragen ...
von: ... neopa C
Geschrieben am: 04.11.2015 19:27:09
Hallo Chris,
... hier meine Antworten:
1.) (E7<>"") Deine Deutung "E7 ungleich?" ist richtig. Das Ergebnis hierfür ist WAHR oder FALSCH
2:) (E7>0)*(E7<>"") ist gleichzusetzen der Teilformel


ODER(E7>0;E7<>"")

Mehr dazu sieh mal hier: http://www.online-excel.de/excel/singsel.php?f=91
3.) zu WENN()-Formeln sieh mal hier: http://www.online-excel.de/excel/singsel.php?f=95 und zu Deiner konkreten Frage soll als Ergebnis der Formel ein "" ausgegeben werden, wenn mindestens eine der beiden Bedingungen aus (E7>0)*(E7<>"") FALSCH ist und das Teilergebnis dieser Bedingungsmultiplikation damit zwingend ein 0 ergibt.
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zeilen Dividieren"