Microsoft Excel

Herbers Excel/VBA-Archiv

Matrixfunktion Zeilen zusammenzählen


Betrifft: Matrixfunktion Zeilen zusammenzählen von: Tobias Hanschen
Geschrieben am: 19.04.2017 11:53:15

Hallo,

mir fehlt leider kein richtiger Betreff ein bzw. die Umschreibung fällt mir schwer.

Also, ich hab ein Excel Dokument in welchem ich mit einer einfachen =Formel den Benutzernamen aus einem anderen Tabellenblatt hole.

Nun sind dort auch leer Zeilen zwischen und die möchte ich gerne zusammen fassen. Dafür habe ich folgendes Skript im Einsatz:

=WENN(ZEILE(1:1)>ZÄHLENWENN(E:E;">=A");"";INDEX(E:E;KKLEINSTE(WENN(E$3:E$150>="A";ZEILE($3:$150)); ZEILE(A1)))) 
Bis zur Zeile 150 klappt das auch Wunderbar, aber ich muss bis zur Zeile 500 kommen. Wenn ich 500 eingebe bzw. einen Wert über 150 wird mir ein Fehler zurückgegeben.

Wie kann ich das lösen? Ist das überhaupt möglich?

Vielen Dank vorab.

Viele Grüße
Tobias

  

Betrifft: AW: Matrixfunktion Zeilen zusammenzählen von: SF
Geschrieben am: 19.04.2017 11:56:43

Hola,

wie lautet denn der Fehler und die Formel dazu?

Gruß,
steve1da


  

Betrifft: AW: Matrixfunktion Zeilen zusammenzählen von: Tobias Hanschen
Geschrieben am: 19.04.2017 12:02:06

Hallo Steve,

die Formel lautet:

=WENN(ZEILE(1:1)>ZÄHLENWENN(E:E;">=A");"";INDEX(E:E;KKLEINSTE(WENN(E$3:E$300>="A";ZEILE($3:$300)); ZEILE(A1)))) 
Die erste Zeile wird dann noch richtig ausgegeben, aber ab der zweiten Zeile kommt der Fehler "#Zahl"


  

Betrifft: AW: Matrixfunktion Zeilen zusammenzählen von: SF
Geschrieben am: 19.04.2017 12:08:57

Hola,

du hast die Formel als Matrixformel abgeschlossen?
Alternativ als normale Formel:

=WENNFEHLER(INDEX(E:E;AGGREGAT(15;6;ZEILE($A$3:$A$300)/($E$3:$E$300<>"");ZEILE(A1)));"")

Gruß,
steve1da


  

Betrifft: AW: Matrixfunktion Zeilen zusammenzählen von: Tobias Hanschen
Geschrieben am: 19.04.2017 12:12:37

Danke für deine Antwort.

Deine Formel funktioniert, aber leider sind weiterhin die Leerzeilen (vermutlich aufgrund der Formel) weiterhin dazwischen/vorhanden.

Ich arbeite die Datei mal eben sonst um und würde die sonst mal hochladen


  

Betrifft: AW: Matrixfunktion Zeilen zusammenzählen von: SF
Geschrieben am: 19.04.2017 12:14:03

Hola,

auf Grund welcher Formel?
Beispieldatei hört sich gut an.

Gruß,
steve1da


  

Betrifft: AW: Matrixfunktion Zeilen zusammenzählen von: Tobias Hanschen
Geschrieben am: 19.04.2017 12:23:20

Anbei der Link zur Datei:
https://www.herber.de/bbs/user/112967.xlsx

Kurze Erklärung zu dem Dokument:
Im Blatt "Import AD" wird eine Liste aus dem AD importiert.
Im Blatt "Prüfungen AD" wird dann geprüft, ob der Benutzer zu einem Bestimmten Bereich gehört (wenn TVS, dann soll der Benutzer ausgeblendet werden)
Im Tabellenblatt "Hilfstabelle" sollen dann die ausgeblendeten Werte weg gelassen werden und die restlichen Werte zusammenrücken. Hier kommt dann auch die besagte Formel zum Einsatz.


  

Betrifft: AW: Matrixfunktion Zeilen zusammenzählen von: SF
Geschrieben am: 19.04.2017 12:29:20

Hola,

Excel gut? Du lässt dir in vielen Formeln an Stelle von "" (leer) " " (Leerzeichen) ausgeben. Das führt dazu, dass diese Zellen natürlich mit übernommen werden, sind ja eben nicht "".
Außerdem ist die Aggregat Formel ohne Strg-Shift-Enter einzugeben. Dann sollte man Fehlermeldungen mit Wennfehler() so früh wie möglich abfangen.

Gruß,
steve1da


  

Betrifft: AW: Matrixfunktion Zeilen zusammenzählen von: Tobias Hanschen
Geschrieben am: 19.04.2017 12:36:22

Danke.
Das hab ich in dem Fall übersehen. Danke dir für die schnelle Hilfe. Funktioniert alles wunderbar.


Beiträge aus den Excel-Beispielen zum Thema "Matrixfunktion Zeilen zusammenzählen"