Microsoft Excel

Herbers Excel/VBA-Archiv

Diagramme


Betrifft: Diagramme von: Bernhard
Geschrieben am: 29.06.2017 10:40:25

Ich möchte ein bzw. mehrere Diagramme erstellen.
Die Werte stehen in einer Gesamttabelle(T1).
Der Datenbereich wird in einem anderen Tabellenblatt (Übersicht) durch eine Formel (=VERGLEICH(B13;'T1'!B:B)+1) ermittelt (z.B. 25)
nächste Spalte (=VERGLEICH(D13;'T1'!B:B) = 256.
Möchte jetzt Diagramme erstellen mit Datenwerten aus dem ermittelten Bereich.
Z.B. T1 A25:256
Nur wie?

  

Betrifft: AW: Diagramme von: Bernhard
Geschrieben am: 29.06.2017 11:54:07

Beispiel Datei https://www.herber.de/bbs/user/114576.xlsx


  

Betrifft: AW: Diagramme von: Luschi
Geschrieben am: 29.06.2017 13:19:04

Hallo Bernhard,

habe die 3 Tabellen-Bereiche als Arbeitsmappen-Bereichsnamen auf der Grundlage der vorgegebenen Tabelle angelegt (siehe Namensmanager: Strg+ F3).
Zur Auswahl gibt es in Zelle Übersichtz!B8 eine Gültigkeitsliste. Um dem Diagramm den neuen Datenbereich zuzuweisen, bedarf es (auch in Excel 2016 leiner immer noch) eines Makro-3-Zeilers.

https://www.herber.de/bbs/user/114579.xlsm

Gruß von Luschi
aus klein-Paris


  

Betrifft: AW: Diagramme von: Bernhard
Geschrieben am: 29.06.2017 15:08:18

Hallo Luschi!

Kann deine Lösung nachvollziehen.
Habe jetzt einen 4 Bereich im Namensmanager angelegt und die Übersicht und T1 um ein paar Daten erweitert.
Wie bekomme ich jetzt den Bereich_4 in die Auswahl damit dieser im Diagramm dargestellt wird?


  

Betrifft: AW: Diagramme von: Luschi
Geschrieben am: 29.06.2017 16:19:45

Hallo Bernhard,

hier das selbe Beispiel nochmal mit ein paar Bemerkungen und der Bildung der Datengültigkeitsliste auf der Grundlage einer formatierten Tabelle.

https://www.herber.de/bbs/user/114587.xlsm

Gruß von Luschi
aus klein-Paris


Beiträge aus den Excel-Beispielen zum Thema "Diagramme"