Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema MsgBox
BildScreenshot zu MsgBox MsgBox-Seite mit Beispielarbeitsmappe aufrufen

Datenprüfung 2 Spalten!


Betrifft: Datenprüfung 2 Spalten! von: Sven Boßhammer
Geschrieben am: 17.07.2017 09:04:32

Hallo an die Gemeinde,

ich habe wieder ein Problem!

Und zwar möchte ich auf 2 Spalten A und C eine Datenprüfung legen.

Ausgangssituation ist die: Spalte A sind Datumswerte und Spalte C ist schon über eine Datenprüfung definiert (Liste mit Werten die erlaubt sind).
Nun möchte ich gerne prüfen lassen und verhindern das in Spalte C am gleichen Tag der gleiche Eintrag steht.

Zum Beispiel:
Spalte A: 01.06.2017 Spalte C: E
Spalte A: 01.06.2017 Spalte C: E

Kann ich überhaupt 2 Datenprüfungen auf eine Spalte legen, oder muß ich diese kombinieren??

Irgendwie bekomme ich das nicht hin!

Wenn etwas unklar ist, dann fragt einfach!

Gruß Sven

  

Betrifft: AW: Datenprüfung 2 Spalten! von: UweD
Geschrieben am: 17.07.2017 09:16:43

Hallo

so??



Tabelle1

 ABCD
104.07.2017 q 
205.07.2017 q 
306.07.2017 E 
406.07.2017   
506.07.2017 A 
608.07.2017 E 
709.07.2017 E 
810.07.2017   
911.07.2017   
1012.07.2017   
1113.07.2017   
1214.07.2017   
1315.07.2017   
1416.07.2017   
1517.07.2017 DMehrfach
1617.07.2017 DMehrfach
1717.07.2017   
1818.07.2017   
1919.07.2017   
2019.07.2017   
2119.07.2017   
2222.07.2017   

verwendete Formeln
Zelle Formel Bereich N/A
D1: D22=WENN(ZÄHLENWENNS(A:A;A1;C:C;C1)>1;"Mehrfach";"")  
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 21.10 einschl. 64 Bit




Kannst du auch über bedingte Formatierung anzeigen lassen

Oder über Datenüberprüfung sogar unterbinden

LG UweD


  

Betrifft: AW: lässt sich möglicherweise kombinieren ... von: ... neopa C
Geschrieben am: 17.07.2017 09:18:55

Hallo Sven,

... aber Deine Erklärung an Hand einer hier hochgeladenen kleinen Daten(auszugs)datei könnte Deine Fragestellung eindeutiger machen.

Gruß Werner
.. , - ...


  

Betrifft: AW: Datenprüfung 2 Spalten! von: Sven Boßhammer
Geschrieben am: 17.07.2017 09:51:06

Hallo Werner,

hier die Datei: https://www.herber.de/bbs/user/114905.xlsm

Wie gesagt habe ich auf Spalte C schon eine Datenüberprüfung mit festen Werten als Liste.
Diese würde ich gerne behalten und um die zusätzliche Datenüberprüfung ergänzen.

Gruß Sven


  

Betrifft: AW: dazu ... von: ... neopa C
Geschrieben am: 17.07.2017 12:17:09

Hallo Sven,

... sorry, ich hole mir keine xlsm-Datei aus dem Internet u.a. auch, weil ich mich nicht mit VBA befasse.

Hab aber mal versucht, Deine anderen bisherigen Angaben zu interpretieren.
Danach meine ich, dass eine Kombination einer zusätzlichen Datengültigkeitsprüfung mit einer Datenliste in der gleichen Zelle und ohne Hilfszellen möglicherweise nur mit einer benutzerdefinierten Datengültigkeit realisierbar ist.

Gruß Werner
.. , - ...


  

Betrifft: AW: dazu ... von: Sven Boßhammer
Geschrieben am: 17.07.2017 12:26:27

Hallo Werner,

das kann ich verstehen und ich habe alle Makros gelöscht und als xlsx-Datei gespeichert.
Da die Problematik sich ja nicht auf die Makros bezieht.

https://www.herber.de/bbs/user/114909.xlsx

Gruß Sven


  

Betrifft: AW: nachgefragt ... und ... von: ... neopa C
Geschrieben am: 17.07.2017 13:06:37

Hallo Sven,

... Du bist noch nicht auf den zweiten Teil meiner Antwort eingegangen. Nachdem ich mir Deine Datei angeschaut hab, käme auch nur das dort geschriebene in Frage, was einerseits mit etwas Aufwand verbunden ist und möglicherweise von Dir nicht gewünscht ist.

Allerdings würde ich sowieso Deine zweite Bedingung nicht in die Datengültigkeit einbinden sondern über bedingte Formatierung visuell aufzeigen, dass eine bestimmte Eingabe nicht vorgenommen werden sollte.

Und zwar folgende bed. Formatierungsformel in C2:C###:

=ZÄHLENWENNS(A:A;A2;C:C;C2)>1 
und diesem z. B. rot für Hintergrund und Schrift zuweisen.

Gruß Werner
.. , - ...


  

Betrifft: AW: dazu ... von: Werner
Geschrieben am: 17.07.2017 15:20:11

Hallo Sven,

hier eine Lösung mit Makro. Das Makron muss ins Codemodul deiner einzelnen Monatsblätter.
Rechtsklick auf den Tabellenblattreiter - Code anzeigen - Code rechts ins Codemodul kopieren.

Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Column <> 3 Then Exit Sub
    If Target.Row >= 2 Then
        On Error Resume Next
        If Not Target Is Nothing Then
            If WorksheetFunction.CountIfs(Range("C:C"), Target.Value, Range("A:A") _
            , Target.Offset(0, -2)) > 1 Then
                MsgBox "Nicht zulässig, Schlüssel '" & Target.Value & _
                "' ist für das Datum '" & Target.Offset(0, -2).Text & _
                "' bereits vorhanden.", , "Hinweis für " & Application.UserName
                Application.EnableEvents = False
                Application.Undo
                Application.EnableEvents = True
            End If
        End If
    End If
Application.EnableEvents = True
On Error GoTo 0
End Sub
Gruß Werner


  

Betrifft: AW: dazu ... von: Sven B.
Geschrieben am: 17.07.2017 18:47:44

Hallo Werner und Werner?,

vielen Dank für eure Bemühungen, die Makro-Variante funktioniert tadellos und ist jetzt sozusagen produktiv im Einsatz!:-) Daumen hoch für dieses Forum!

Gruß Sven


  

Betrifft: Gerne u. Danke für die Rückmeldung. o.w.T. von: Werner
Geschrieben am: 17.07.2017 18:54:52