Microsoft Excel

Herbers Excel/VBA-Archiv

Für ZÄHLENWENNS das Kriterium erst per VERWEIS


Betrifft: Für ZÄHLENWENNS das Kriterium erst per VERWEIS von: Sebastian
Geschrieben am: 18.07.2017 17:52:48

Hallo,

ich suche eine Weg eine Zwischentabelle zu ersparen und die Zählung direkt in einer Zelle durchzuführen.

Die Tabellen:
1. Tabelle: Mitarbeiteraktivitäten
Mitarbeiter|KW1|KW2|KW3|KW4
Max|URB|KRK|TAG|TAG
Moritz|URB|TAG|TAG|TAG

2. Aktivitätstypen:
Kürzel|Name|Typ
URB|Urlaub|Abwesend
KRK|Krankheit|Abwesend
TAG|Tagesgeschäft|Anwesend

Per Formel möchte ich nun zählen wie viele Aktivitäten Max vom Typ "Abwesend" in den KW1 bis KW4 hatte. Ergebnis sollte also zwei sein.

Die Lösung über eine Hilfstabelle, die für Max erst per SVERWEIS je KW den Typ ausliest und dann per ZÄHLENWENN über die Hilfstabelle das Ergebnis ermittelt möchte ich gerne vermeiden und diese beiden Schritte kombinieren. Kann mir hier jemand de entscheidenden Tipp geben?

Vielen Dank schon Mal an alle die sich an der Lösungsfindung beteiligen!

  

Betrifft: AW: z.B. mit SUMMENPRODUKT() von ZÄHLENWENN() ... von: ... neopa C
Geschrieben am: 18.07.2017 18:03:04

Hallo Sebastian,

... so Formel nach unten kopieren

 ABCDEFGHIJK
1MitarbeiterKW1KW2KW3KW4 Abwesend KürzelNameTyp
2MaxURBKRKTAGTAG 2 URBUrlaubAbwesend
3MoritzURBTAGTAGTAG 1 KRKKrankheitAbwesend
4        TAGTagesgeschäftAnwesend
5           

Formeln der Tabelle
ZelleFormel
G2=SUMMENPRODUKT(ZÄHLENWENN(B2:E2;I$2:I$3))


Gruß Werner
.. , - ...


  

Betrifft: AW: z.B. mit SUMMENPRODUKT() von ZÄHLENWENN() ... von: Sebastian
Geschrieben am: 18.07.2017 19:02:50

Dank für die Antwort, leider erfasst sie nicht das ganze Problem. Der Suchkriterien-Bereich im Zählenwenn ist genau auf die beiden Werte eingeschränkt die Abwesend sind und es findet kein echter Lookup gegen Spalte K statt.

Die Reihenfolge der Einträge in der Aktivitätstypen-Übersicht kann ich leider nicht beeinflussen. D.h. es könnte auch die Reihenfolge URB, TAG, KRK sein oder morgen kommt AUS (Typ abwesend) für Ausbildung dazu.

Der Weg sollte sein:
1. Nimm Wert aus KW für Mitarbeiter und schaue für diesen den Typen nach
2. Zähle wenn Typ von Wert "abwesend" bzw. x


  

Betrifft: AW: das "ganze..." hattest Du nicht dargestellt... von: ... neopa C
Geschrieben am: 18.07.2017 19:23:50

Hallo nochmal,

... wenn dem so ist, wie Du jetzt schreibst, ist die einfachste und schnellste Lösung die, Deine Typenliste nach Typ aufwärts zu sortieren. Dann müsste meine Formel nur leicht erweitert werden.

 ABCDEFGHIJK
1MitarbeiterKW1KW2KW3KW4 Abwesend KürzelNameTyp
2MaxURBKRKTAGTAG 2 URBUrlaubAbwesend
3MoritzURBTAGSONURB 3 KRKKrankheitAbwesend
4        SonSonstigAbwesend
5        TAGTagesgeschäftAnwesend
6           

Formeln der Tabelle
ZelleFormel
G2=SUMMENPRODUKT(ZÄHLENWENN(B2:E2;I$2:INDEX(I:I;ZÄHLENWENN(K:K;"Abwesend")+1)))


Gruß Werner
.. , - ...


Beiträge aus den Excel-Beispielen zum Thema "Für ZÄHLENWENNS das Kriterium erst per VERWEIS"