Microsoft Excel

Herbers Excel/VBA-Archiv

Zellenabfrage


Betrifft: Zellenabfrage von: Florian
Geschrieben am: 29.07.2017 11:17:47

Hallo,

ich habe mir eine Formel zusammengebastelt, die nicht funktionieren möchte. Ich komme nur nicht darauf, wo mein Fehler steckt.

Sie ist auch noch nicht ganz fertig, ich scheitere gerade an der ersten Stufe.

Hier die bisherige Formel:

=WENN(ODER(B2;B3;B4;B5;B6;B7)=ODER("a";"");ja;nein)

In den Zellen B2 bis B7 können einzelene Buchstaben von a-z (keine Umlaute, keine Zahlen) stehen.
Hier soll, wenn in einer der Zellen ein "a" steht oder eine der Zellen leer ist ein "ja" geschrieben werden, sonst ein "nein".

In Step 2 möchte ich statt "a" den ersten Buchstaben eines Wortes in einer Zelle (Bsp.: A10) prüfen. kann ich dann einfach "a" durch links(A10;1) abändern?

Außerdem möchte ich statt ja oder nein später die Zelle farbig werden lassen. grün oder rot. Wie das geht weiß ich noch gar nicht, wenn ihr mir da nicht helfen könnt wäre das auch nicht so schlimm.

In Step 3 möchte ich dann zusätzlich den zweiten Buchsteben des Wortes prüfen der in den Zellen C2 bis C7 steht.
Das stelle ich mir dann so vor:

=WENN((ODER(B2;B3;B4;B5;B6;B7)=ODER(links(A10;1);"");ja;nein)und(ODER(C2;C3;C4;C5;C6;C7) =ODER(links(A10;2);"");ja;nein)

Geht das?

Vielen Dank für eure Hilfe
Gruß
Florian

  

Betrifft: AW: Zellenabfrage von: Hajo_Zi
Geschrieben am: 29.07.2017 11:29:06

Hallo Florian,

für die Überprüfung benutze Zählenwenn()


GrußformelHomepage

Ich gebe keinen Dank für eine Rückmeldung, da ich durch solche Beiträge nicht meine Beitragszahl erhöhen muss.
Rückmeldung ist ja in der Heutigen Zeit nicht üblich und die wenigen die eine Rückmeldung geben, mögen mir das verzeihen, das kein Danke für eine Rückmeldung kommt.


  

Betrifft: AW: Zellenabfrage von: Florian
Geschrieben am: 29.07.2017 11:37:17

Hallo Hajo_Zi,

ich weiß nicht, wie du Zählenwenn hier einbauen möchtest.
Ich möchte das in der Zelle ein ja steht wenn in der Zelle ein "a" steht. Aber auch wenn die Zelle leer ist.

Könntest du auch auf die anderen Punkte eingehen?

Gruß
Florian


  

Betrifft: AW: Zellenabfrage von: Hajo_Zi
Geschrieben am: 29.07.2017 11:40:52

Hallo Florian,

Könntest du auch auf die anderen Punkte eingehen?

es ging nur um die Formel und das habe ich gelöst.

ich sehe kein offenes Problem, in Deinem letzten Beitrag.
Excel hat auch eine Hilfe, falls Zählöenwenn nicht klar.


Gruß Hajo


  

Betrifft: AW: Zellenabfrage von: Florian
Geschrieben am: 29.07.2017 11:44:12

Könntest du mir dann noch sagen, wie ich statt ja oder nein die Zelle einfach nur Fabrig mache als Ausgabe der wenn Bedingung?


  

Betrifft: AW: Zellenabfrage von: Hajo_Zi
Geschrieben am: 29.07.2017 11:47:18

benutze die bedingte Formatierung, Zellwert = "Ja"

Gruß Hajo


  

Betrifft: AW: Zellenabfrage von: Werner
Geschrieben am: 29.07.2017 15:51:31

Hallo Florian,

meinst du so?

=WENN(ODER(ZÄHLENWENN(B2:B7;LINKS(A10;1));ZÄHLENWENN(B2:B7;""));"ja";"nein")

Wenn die Formel so passt dann Frage bezüglich der Färbung der Zelle:
Wann soll sich die Zelle färben? Bei Ergebnis "ja" oder bei Ergebnis "nein"

Gruß Werner