Microsoft Excel

Herbers Excel/VBA-Archiv

Zellinhalt autom. mit übernehmen.


Betrifft: Zellinhalt autom. mit übernehmen. von: Micha
Geschrieben am: 26.09.2017 01:04:03

Hallo,

ich möchte das bei Änderung der Zellposition die Nachbarzelle autom. mit in die Änderung einbezogen wird. Da es für mich nicht leicht ist, dieses Problem gut zu beschreiben, habe ich eine kleine Datei mit beigefügt. Hoffe Ihr könnt damit etwas anfangen.

Gruß
Micha

https://www.herber.de/bbs/user/116517.xlsx

  

Betrifft: AW: Zellinhalt autom. mit übernehmen. von: JoWE
Geschrieben am: 26.09.2017 07:13:41

Hallo Micha,

woher stammen denn die Beträge in Spalte C? Doch vermutlich aus der Datei lt. Spalte A?
Falls dem so ist, könnte vielleicht die Funktion SVerweis helfen.

Gruß
Jochen


  

Betrifft: Zellinhalt autom. mit übernehmen. An JoWE von: Micha
Geschrieben am: 26.09.2017 10:16:14

Hallo Jochen,

die Werte aus Spalte "C", sind die Werte aus dem Vorjahr (2016) einer gleichen Tabelle, und dienen zum
Vergleich, ob es sich um Gewinn oder Verlust handelt.
Bitte schau Dir noch einmal den Anhang an. Da siehst Du es besser.
Danke und Gruß
Micha

https://www.herber.de/bbs/user/116528.xlsx


  

Betrifft: AW: Zellinhalt autom. mit übernehmen. An JoWE von: JoWE
Geschrieben am: 26.09.2017 12:41:47

Micha,

ja, gesehen; kenne nicht den Aufbau der Tabelle "Kasse" des Vorjahres. Aber sollte doch mit einer Verweis-Funktion funktionieren. Notfalls müsstest Du die Vorjahrestabelle "Kasse" evtl. umstrukturieren.

Wenn dann in der Vorjahrestabelle "Kasse" sowohl die Begriffe zu "Posteneinnahme" z.B. in Spalte Y und die zugehörigen Summen in der jeweils gleichen Zeile der Spalte Z stehen würden, könnte Deine Formel so aussehen:
=SVERWEIS(A3;'[externe VorjahresArbeitsmappe.xlsx]'Kasse!$Y$3:$Z$31;2;FALSCH).
Schau Dir dazu mal die Hilfe dazu von MS an:
https://support.microsoft.com/de-de/help/181213/how-to-use-vlookup-or-hlookup-to-find-an-exact-match

Statt SVERWEIS könntest Du auch mit INDEX und VERGLEICH arbeiten, wobei hier im Forum Cracks sind, die das viel besser hinkriegen als ich. Aber natürlich müssten auch die die Struktur der Tabelle "Kasse" kennen.

Gruß
Jochen


  

Betrifft: AW: Zellinhalt autom. mit übernehmen. An JoWE von: JoWE
Geschrieben am: 26.09.2017 15:16:55

Nachtrag:

Die Formel =SVERWEIS(A3;'[externe VorjahresArbeitsmappe.xlsx]'Kasse!$Y$3:$Z$31;2;FALSCH)
kannst Du dann runterziehen. Und damit ist dann völlig egal wo in der Spalte A der Posteneinnahmebegriff steht, weil die Formel ja nach dem Begriff laut Spalte A (Parameter1) in der Tabelle Kasse (Parameter2) sucht und den rechts daneben stehenden Wert (Parameter3) zurückgibt.

Greuß
Jochen


  

Betrifft: Zellinhalt autom. mit übernehmen. An JoWE von: Micha
Geschrieben am: 26.09.2017 18:30:08

Hallo Jochen,

habe Dir zum besseren Verständnis noch mal die Datei aus dem Vorjahr beigefügt.
Ich weiß, dass es nicht leicht ist, die Gedanken des Anderen zu verstehen. Das Grundprinzip meines Problems ist, das die Zellen A3:A31 und C3:C31 immer parallel "verschoben" werden sollen. Allerdings
kommen die Werte in Spalte C aus einer anderen Datei mit Verweis auf den Pfad usw.
Vielleicht kannst Du mir nochmal beistehen.
Gleichzeitig werde ich mir Deinen beigefügten Link ansehen.
Vielen Dank nochmal
Gruß Micha

https://www.herber.de/bbs/user/116547.xlsx "Kassenbuch 2016"
https://www.herber.de/bbs/user/116548.xlsx "Testdatei V1.1"


  

Betrifft: AW: Zellinhalt autom. mit übernehmen. An JoWE von: JoWE
Geschrieben am: 26.09.2017 20:19:46

Hallo Micha,

ich hatte schon verstanden was Du erreichen willst.
Allerdings fällt mir keine andere Lösung ein.
Bin daher raus und stelle Dein Problem wieder auf offen.

Gruß
Jochen


  

Betrifft: Zellinhalt autom. mit übernehmen. An JoWE von: Micha
Geschrieben am: 27.09.2017 07:23:20

Hallo Jochen,

eine Frage habe ich noch.
Wie kann ich den Thread selber schließen?

Gruß Micha


  

Betrifft: Kontrollkästchen deaktivieren ... von: Matthias L
Geschrieben am: 27.09.2017 08:21:14

Hallo

Indem Du das Kontrollkästchen neben dem Passwort deaktivierst.

Aktiviere das Kontrollkästchen, wenn die Frage mit diesem Beitrag nicht beantwortet wurde und der Thread weiter bei den offenen Fragen angezeigt werden soll

Info
Wenn Du im Beitragsbetreff immer den Zusatz schreibst
An JoWE ... (an Chris) usw., sieht es so aus als ob Du von niemanden anderes Hilfe möchtest.

Wenn dem so ist, dann vergiss meine Antwort.

Gruß Matthias


Beiträge aus den Excel-Beispielen zum Thema "Zellinhalt autom. mit übernehmen."