Microsoft Excel

Herbers Excel/VBA-Archiv

Preisformel


Betrifft: Preisformel von: MK
Geschrieben am: 27.09.2017 09:08:41

Hallo zusammen,

ich bin auf der Suche nach einer ziemlich komplizierten Formel. Ich hoffe Ihr könnt mir weiter helfen.
Unter den folgenden Link findet Ihr zwei Mustertabellen
https://www.herber.de/bbs/user/116563.xls

Dort möchte ich in der Tabelle 2, Spalte D (baseprice) den Wert aus Tabelle 1, Spalte E (price) haben. Dieser soll anhand der Artikelnummern abgeglichen werden.
Allerdings soll der Wert (falls in Tabelle 1, Spalte D ein "J" vorhanden) ist multipliziert werden mit dem Wert aus Spalte C, Tabelle 1.

Ich hoffe es ist einigermaßen verständlich.
Vielleicht kann mir ja jemand helfen.

Schöne Grüße
MK

  

Betrifft: AW: Preisformel von: {Boris}
Geschrieben am: 27.09.2017 09:15:00

Hi,

zum Beispiel in D2:

=SVERWEIS(C2;Tabelle1!$A:$E;5;)*WENN(SVERWEIS(C2;Tabelle1!$A:$E;4;)="J";SVERWEIS(C2;Tabelle1!$A:$E;3; );1)

und runterkopieren.

VG, Boris


  

Betrifft: AW: Preisformel von: MK
Geschrieben am: 27.09.2017 09:18:59

Hallo Boris,

super vielen Dank. Es funktioniert!
Eine Frage habe ich allerdings noch, hast du den Abgleich Anhand der Artikelnamen gemacht,
weil diese sich in der Spalte C befinden?

Schöne Grüße
MK


  

Betrifft: AW: Preisformel von: {Boris}
Geschrieben am: 27.09.2017 09:22:05

Hi,

ja, habe ich (gesucht wird ja nach C2). Das musst Du anpassen, wenn Du nach den Nummern suchen möchtest.

VG, Boris


  

Betrifft: AW: Preisformel von: MK
Geschrieben am: 27.09.2017 09:24:36

Ok, das habe ich gemacht, in dem ich alle Felder mit C in A umgeändert habe.
Allerdings funktioniert dann die Formel nicht mehr.

Grüße
MK


  

Betrifft: AW: Preisformel von: {Boris}
Geschrieben am: 27.09.2017 09:25:48

Hi,

sag, was Du genau möchtest. Die angewandte SVERWEIS-Funktion funktioniert nur von links nach rechts. Alternativen gibt es mit INDEX. Also: Was soll genau gesucht werden?

VG, Boris


  

Betrifft: AW: Preisformel von: MK
Geschrieben am: 27.09.2017 09:29:07

Hallo,

der Abgleich soll über die Artikelnummern geschehen, da die Artikelnamen unterschiedlich in den jeweiligen Tabellen sein können.

Grüße
MK


  

Betrifft: AW: Preisformel von: MK
Geschrieben am: 27.09.2017 09:31:13

Hallo Boris,

ich habe es nun glaube ich hinbekommen.
Habe die Formel wie folgt umgeändert:
=SVERWEIS(A2;Tabelle1!$B:$E;4;)*WENN(SVERWEIS(A2;Tabelle1!$B:$E;3;)="J";SVERWEIS(A2;Tabelle1!$B:$E;2; );1)

Vielen vielen Dank für deine Hilfe.
Hast mir sehr weiter geholfen.

Grüße
MK