Microsoft Excel

Herbers Excel/VBA-Archiv

Index Sverweis


Betrifft: Index Sverweis von: Marcel
Geschrieben am: 06.11.2017 14:36:09

Hallo zusammen

Ich habe ein Excel Problem, bei dem ich alleine nicht mehr weiterkomme.
Im Tabellenblatt "Kunden aktiv" trage ich jeweils die Kundendaten ein, die einen oder mehrere Kurse besuchen (Spalte E + F)
Im Tabellenblatt "Anwesenheit" möchte ich nun nach den Kurszeiten sortiert eine Auflistung der Namen und Vornamen erstellen, um so die Anwesenheit überprüfen zu können.

Mein Problem ist nun, dass ich mittels der im Tabellenblatt "Anwesenheit" erstellten Formel (A3) immer nur den selben Namen und Vornamen erhalte, respektive #NV.

https://www.herber.de/bbs/user/117476.xlsx

Wer hat eine passende Lösung zur Hand oder will ich etwas unmögliches?

Freundliche Grüsse aus der Schweiz
Marcel

  

Betrifft: AW: Index Sverweis von: SF
Geschrieben am: 06.11.2017 14:50:15

Hola,

es gibt im Blatt Anwesenheit den Kurs "Erw. Montag 18 - 19 Uhr", im Blatt "Kunden aktiv" ist zusätzlich noch der Kurs "Montag 18 - 19 Uhr" eingetragen. Für Excel sind das verschiedene Datensätze. Ansonsten:

=WENNFEHLER(INDEX('Kunden aktiv'!C$2:C$51;AGGREGAT(15;6;ZEILE($A$2:$A$51) -1/(('Kunden aktiv'!$E$2:$E$51=$A$1)+('Kunden aktiv'!$F$2:$F$51=$A$1));ZEILE(A1)));"")

Für den 2. Kurs dann aus =$A$1 jeweils =$A$16 machen, usw.

Gruß,
steve1da


  

Betrifft: AW: Index Sverweis von: Marcel
Geschrieben am: 06.11.2017 15:24:24

Genial!!!

Vielen herzlichen Dank!!


  

Betrifft: AW: Index Sverweis von: Marcel
Geschrieben am: 06.11.2017 15:24:31

Genial!!!

Vielen herzlichen Dank!!


Beiträge aus den Excel-Beispielen zum Thema "Index Sverweis"