Microsoft Excel

Herbers Excel/VBA-Archiv

20 % Abweichung


Betrifft: 20 % Abweichung von: Max
Geschrieben am: 15.01.2018 16:01:03

Hallo liebes Forum!

Ich stehe gerade vor folgendem Problem:

In vier benachbarten Zellen stehen Jahreswerte.
Wenn einer dieser Werte um mindestens 20 % geringer ist, als der vorhergehende, soll er bei einer Mittelwertberechnung nicht berücksichtigt werden. Der Mittelwert muss jedoch aus 3 von 4 Jahren gebildet werden. Wenn mehrere Werte um mehr als 20 % abweichen, wird dies nicht berücksichtigt. Ich habe schon ellenlange Wennformeln probiert, die leider alle nicht zum gewünschten Ergebnis geführt haben. Ich habe ein Muster angehängt vielleicht kennt ja jemand eine Lösung für das Problem.

Gruß Max

https://www.herber.de/bbs/user/118982.xlsx

  

Betrifft: AW: nachgefragt ... von: ... neopa C
Geschrieben am: 15.01.2018 18:47:02

Hallo Max,

... welcher Mittelwert soll denn bei z.B. für 10 5 6 7 ermittelt werden oder welcher bei 10 8 6,5 6 ?

Gruß Werner
.. , - ...


  

Betrifft: AW: nachgefragt ... von: Max
Geschrieben am: 15.01.2018 19:22:37

Hallo Werner!
Welcher Mittelwert berechnet werden soll hängt von den Werten ab.
Es sind immer 3 Zahlen notwendig. Ein "Außreißer" soll dabei nicht mit einbezogen werden.
Standardmäßig soll der Mittelwert aus den drei rechten Zahlen gebildet werden, es sei denn ein Wert weicht um mehr als 20 % nach unten ab, dann wird der linke Wert mit einbezogen.

Schonmal vielen Dank fürs Gedanken machen!

Gruß Max


  

Betrifft: AW: 20 % Abweichung von: onur
Geschrieben am: 15.01.2018 19:26:13

Einmal sprichst du von 20% geringer und einmal von 20% Abweichung.
Was ist denn richtig?
Abweichung allgemein oder negative Abweichung?


  

Betrifft: AW: 20 % Abweichung von: Manuel
Geschrieben am: 15.01.2018 22:45:13

Hallo Max

Ich habe eine Formel gebastelt, welche funktionieren sollte.

=WENN(SUMME(WENN(100/A2*B2<80;0;1);WENN(100/B2*C2<80;0;1);WENN(100/C2*D2<80;0;1))=1;
"Zu wenig gültige Werte";MITTELWERT(WENN(100/A2*B2<80;$A$2;B2);WENN(100/B2*C2<80;$A$2;C2);
WENN(100/C2*D2<80;$A$2;D2)))
Diese Formel prüft ob mehr als ein Eintrag gültig ist, ist dies der Fall wird der Mittelwert aus den drei gültigen Werten, bzw. aus den zwei Gültigen und dem Letzten gezogen. Ansonsten wird "Zu wenig gültige Werte" ausgegeben.


Es ist allerdings nicht empfehlenswert, solch lange Formeln zu verwenden, da sie fast nicht mehr wartbar sind.
Ich empfehle stattdessen mehrere kleine Formeln in versteckten Zellen zu verwenden.

Gruss

Manuel


Beiträge aus dem Excel-Forum zum Thema "20 % Abweichung"