Microsoft Excel

Herbers Excel/VBA-Archiv

Indirekt


Betrifft: Indirekt von: Tom
Geschrieben am: 29.03.2018 13:29:27

Hallo zusammen,

ich habe diese Formel:
=SVERWEIS(A4;INDIREKT(Zusammenfassung!B2&"!A:K");7;FALSCH)

mit der Zusammenfassung B2 steht der Kunde drin und ziehe mir die Daten auf die ganzen Tabellenblätter ( Kunde)
Spalte A sind Artikeltexte

Ich möchte aber zusätzlich noch Abfangen wenn in Tabellenblatt Zusammenfassung in B3 das Jahr steht, soll er nur den Wert auslesen. Das Datum steht in der Spalte F der jeweiligen Tabellenblätter Kunde.

WENN Artikelnummer und Datum gleich ist dann soll er Spalte G herausgeben

Ich hoffe ihr könnt mir helfen

Danke an alle.

Leider kann die diese Datei nicht hochladen.

  

Betrifft: AW: Indirekt von: SF
Geschrieben am: 29.03.2018 13:32:38

Hola,

http://www.excelformeln.de/formeln.html?welcher=30

die dortigen Verweis Formeln sind recht einfach anzupassen.

Gruß,
steve1da


  

Betrifft: AW: dazu kann ich nurdirekt festzustellen .... von: ... neopa C
Geschrieben am: 29.03.2018 14:07:27

Hallo Tom,

... dass man nur spekulieren kann, was Du anstrebst.

So z.B. ist nicht eindeutig:
- "WENN Artikelnummer und Datum gleich ist " diese können gar nicht gleich sein
- "...Spalte A sind Artikeltexte ..." und wo stehen dann die Artikelnummern?
- "wenn in Tabellenblatt Zusammenfassung in B3 das Jahr steht, soll er nur den Wert auslesen" D.h. einfach nur: =Zusammenfassung!B3. Aber das willst Du möglicherweise nicht! Oder?

Du musst auch nicht Deine Datei einstellen, aber hilfreicher wäre schon eine Datei mit Deiner Datenstruktur mit ein paar Dummydaten anstelle Deiner Originaldaten.

Gruß Werner
.. , - ...


  

Betrifft: AW: dazu kann ich nurdirekt festzustellen .... von: Tom
Geschrieben am: 29.03.2018 17:54:57

Hallo zusammen,

anbei die Datei:

https://www.herber.de/bbs/user/120765.xlsx


  

Betrifft: AW: mit einer Menge VERWEIS()e ... von: ... neopa C
Geschrieben am: 29.03.2018 20:20:29

Hallo Tom,

.... in B4 folgende Formel und diese nach rechts und unten kopieren.

=WENNFEHLER(VERWEIS(9;1/(INDIREKT(VERWEIS(9;1/($A$2:B$2<>"");$2:$2)&"!A1:A99")=$A4) /(INDIREKT(VERWEIS(9;1/($A$2:B$2<>"");$2:$2)&"!F1:F99")=B$3);INDIREKT(VERWEIS(9;1/($A$2:B$2<>""); $2:$2)&"!G1:G99"))&"";"")


Gruß Werner
.. , - ...


  

Betrifft: AW: mit einer Menge VERWEIS()e ... von: Tom
Geschrieben am: 30.03.2018 09:23:40

Hey danke dir

kannst du mir irgenwie die Formel erklären ?
Ich Blick null durch

danke dir


  

Betrifft: AW: Deine Frage kann ich mit Ja beantworten, ... von: ... neopa C
Geschrieben am: 30.03.2018 16:40:29

Hallo Tom,

... doch eine Erklärung dieser Formel benötigt ein vielfaches an Zeit, als ich benötigt hatte, diese Formel aufzustellen. Bereits dafür hab ich glaube schon ca. 10 Minuten gebraucht.

Zu ähnlichen VERWEIS()-Konstrukten hab ich schon mehrfach Erklärungen hier im Forum in anderen threeads eingestellt, Der Unterschied dieser Formel zu den von mir bereits erklärten ist "lediglich", dass hier eine Schachtelung von derartigen VERWEIS()-Formeln vorgenommen wurde und dies dazu noch in Kombination mit INDIREKT(). Infolge Deiner Aussage "Ich Blick null durch" müsste ich zudem so interpretieren, dass ich außerdem bei "Null" anfangen müsste. Das sprengt jedoch meinen Zeitrahmen von Forumshilfe. Sorry. Kannst Du Deine Frage evtl. konkretisieren?

Gruß Werner
.. , - ...


  

Betrifft: AW: Deine Frage kann ich mit Ja beantworten, ... von: Tom
Geschrieben am: 30.03.2018 18:06:28

Hey,

ich glaube ich muss Excel mal lernen, damit ich mal so gut werde wie du :-)

Kann man die Formel einbauen, das er nicht den Text zurückgibt sondern nur ein X

Wenn was drinsteht dann soll ein x rein.


  

Betrifft: AW: dann z.B. mit einem zusätzlichen WENN() ... von: ... neopa C
Geschrieben am: 30.03.2018 18:52:31

Hallo Tom,

...in B4 so:

=WENNFEHLER(WENN(VERWEIS(9;1/(INDIREKT(VERWEIS(9;1/($A$2:B$2<>"");$2:$2)&"!A1:A99")=$A4)
/(INDIREKT(VERWEIS(9;1/($A$2:B$2<>"");$2:$2)&"!F1:F99")=B$3);INDIREKT(VERWEIS(9;1
/($A$2:B$2<>"");$2:$2)&"!G1:G99"))<>"";"x";"");"")

und Formel wieder nach rechts und unten ziehend kopieren.

Gruß Werner
.. , - ...


  

Betrifft: AW: dann z.B. mit einem zusätzlichen WENN() ... von: Tom
Geschrieben am: 31.03.2018 10:34:09

Danke für alles


  

Betrifft: WERNER bitte um Hilfe von: Tom
Geschrieben am: 02.04.2018 11:58:51

Hallo Werner,

mein Chef will die Auswertung wie Tabellenblatt Zusammenfassung2 haben. Ich habe versucht deinen Code anzupassen , aber ich check das nicht. Könntest du mir noch einmal helfen.+

https://www.herber.de/bbs/user/120800.xlsx

Danke


  

Betrifft: AW: die Formel enztsprechend umstellen, ... von: ... neopa C
Geschrieben am: 02.04.2018 13:20:29

Hallo Tom,

... sollte kein großes Problem sein. Hab momentan keinen Zugriff auf Excel, melde mich aber heute noch.

Gruß Werner
.. , - ...


  

Betrifft: AW: beide Varianten zur Auswahl ... von: ... neopa C
Geschrieben am: 02.04.2018 18:34:34

Hallo Tom,

... werden wesentlich so wesentlich kürzer.

Die Ausgabe der erfassten Texte erfolgt in D2 mit folgender Formel:

=WENNFEHLER(VERWEIS(9;1/(INDIREKT(C$1&"!A1:A99")=$A2)/(INDIREKT(C$1&"!F1:F99")=$B2);INDIREKT(C$1&"!G1:G99"))&"";"") die nach rechts und unten zu kopieren ist.

Und wenn wieder nur "x" gefragt sein sollten, so:

=WENNFEHLER(WENN(VERWEIS(9;1/(INDIREKT(C$1&"!A1:A99")=$A2)/(INDIREKT(C$1&"!F1:F99")=$B2); INDIREKT(C$1&"!G1:G99"))<>"";"x";"");"")


Gruß Werner
.. , - ...


Beiträge aus dem Excel-Forum zum Thema "Indirekt"