Microsoft Excel

Herbers Excel/VBA-Archiv

Zwei Bedingungen suchen


Betrifft: Zwei Bedingungen suchen von: Simone
Geschrieben am: 23.09.2019 11:37:18

Hallo zusammen,

folgendes Problem habe ich mit einer Tabelle:

Spalte A = lfd. Nummerierung
Spalte B = Kalenderwochen (bspw. 38 / 2019)
Spalte C = Tätigkeit Montag
Spalte D = Tätigkeit Dienstag
Spalte E = Tätigkeit Mittwoch
Spalte F = Tätigkeit Donnerstag
Spalte G = Tätigkeit Freitag
Spalte H = Name des Kollegen

Manche Kollegen schreiben jetzt in den Bereich C bis G (Tätigkeit) zusätzlich zu Ihrer Tätigkeit den Begriff "Pool" rein. Bspw. "Außendienst und Pool"

Ich würde jetzt gerne in der Zelle I1 die Kalenderwoche eintragen bspw 38 / 2019 und I2 soll mir die Zeile wiedergeben, in der der letzte Kollege in der KW 38 / 2019 irgendwo im Tätigkeitsfeld (C:G) das Wort "Pool" eingetragen hat.

Geht sowas?

Lieben Dank und viele Grüße
Simone

  

Betrifft: Zeile bestimmen und KW ausgeben von: WF
Geschrieben am: 23.09.2019 12:03:40

Hi,

=INDEX(B1:B99;SUMMENPRODUKT(ISTZAHL(FINDEN("pool";C1:G99))*(ZEILE(X1:X99))))

WF


  

Betrifft: AW: Zeile bestimmen und KW ausgeben von: Simone
Geschrieben am: 23.09.2019 13:03:07

Hallo WF,

danke für die schnelle Antwort.

So ganz funktioniert es nicht. In I1 steht die KW. Wie kann ich I1 in die
Formel integrieren, damit ich anhand der KW die letzte Eintragung mit "*Pool*" in C:G
suchen kann?

Danke und Grüße
Simone


  

Betrifft: AW: Zeile bestimmen und KW ausgeben von: Rudi Maintaire
Geschrieben am: 23.09.2019 13:09:46

Hallo,
=SUMMENPRODUKT((B1:B99=I1)*ISTZAHL(SUCHEN("pool";C1:G99))*(ZEILE(X1:X99)))

Gruß
Rudi


Beiträge aus dem Excel-Forum zum Thema "Zwei Bedingungen suchen"