Microsoft Excel

Herbers Excel/VBA-Archiv

Bed. Formatierung, wenn alle Beding. erfüllt.


Betrifft: Bed. Formatierung, wenn alle Beding. erfüllt. von: Vanadium
Geschrieben am: 28.09.2019 09:47:42

Guten Morgen,

ich nutze Excel zur Erstellung von Stundenplänen und habe in diesem Zusammenhang ein Minimalbeispiel vorbereitet:

https://www.herber.de/bbs/user/132254.xlsx

Kurze Erklärung des Beispiels:
Die Spalten A - E zeigen die Lehrerzuordnung in den verschiedenen Klassen.
So ist in Klasse 1 z.B. die Lehrkraft "LiMa" in den ersten beiden Stunden eingesetzt, während in Klasse 2 die Lehrkraft "BuJo" in den Stunden 1 bis 4 unterrichtet.

Die Spalten G bis J überwachen die Lehrerzuordnung durch Prüfziffern.
Wird ein Lehrer zur selben Stunde in mehreren Klassen eingesetzt, ist die Prüfziffer größer als 1. Das Feld wird rot markiert und der Stundenplan muss nachgearbeitet werden, da es sonst zu einer Überschneidung kommt.
Sind die Prüfziffern = 1, sind die Felder grün und es kommt zu keiner Überschneidung.
Ist zur entsprechenden Stunde die Lehrkraft nicht eingesetzt, ist die zugehörige Prüfziffer = 0 und das Feld weiß. Hier kann die Lehrkraft noch verplant werden.

Nun zu meinem Anliegen:
Über den entsprechende Lehrkräften ist ein Feld "Auswahl" (blau).
Wenn ich für einen Lehrer dieses Feld durch z.B. ein X markiere, dann sollen
im Stundenplan (also in den Spalten C bis E) alle Felder farbig hervorgehoben werden, die

a) LEER sind und
b) in denen ich diese Lehrkraft noch verplanen könnte.

Beispiel: Ich markiere das Auswahlfeld von "LiMa" mit einem X:
Die bedingte Formatierung soll folgende Zellen hervorheben:
Klasse 1 - Stunde 6 und 10; Klasse 2 - Stunde 6 und 10; Klasse 3 - Stunde 6, 9 und 10.

Ich hoffe, ihr habt eine Idee, wie sich das realisieren lässt.

VG

  

Betrifft: AW: Bed. Formatierung, wenn alle Beding. erfüllt. von: Boris
Geschrieben am: 28.09.2019 10:11:44

Hi,

Wenn ich für einen Lehrer dieses Feld durch z.B. ein X markiere

Genau davon gehe ich aus (sind mehrere x vorhanden, wird das erste x "gewertet"):

Markiere C7:E16, beginnend bei C7.

Bedingte Formatierung, Neue Regel, Formel zur Ermittlung...:

=(INDEX($H$7:$J$16;ZEILE($A1);VERGLEICH("x";$H$5:$J$5;))=0)*(C7="")

und eine Hintergrundfarbe zuweisen.

Kleiner Tipp am Rande:

Formel in H7:
=ZÄHLENWENNS($C7:$E7;H$6)
lässt sich bis J16 kopieren. Ist halt nur EINE Formel.

VG, Boris


  

Betrifft: Und zudem... von: Boris
Geschrieben am: 28.09.2019 10:30:49

Hi,

...braucht es hier nicht ZÄHLENWENNS (habe ich gerade erst gesehen, dass Du diese Funktion verwendet hast):

=ZÄHLENWENN($C7:$E7;H$6)

wäre die Formel der Wahl.

VG; Boris


  

Betrifft: AW: Bed. Formatierung, wenn alle Beding. erfüllt. von: Vanadium
Geschrieben am: 28.09.2019 10:33:38

Hallo Boris,

vielen Dank!
Das funktioniert einwandfrei!
Hammer!