Microsoft Excel

Herbers Excel/VBA-Archiv

Häufigstes Vorkommen

Betrifft: Häufigstes Vorkommen von: Christoph Sattler
Geschrieben am: 25.01.2020 11:18:56

Hallo,


ich habe eine Liste mit ca. 400 Geburtsdaten - jetzt möchte ich gerne wissen, an welchem Tag die meisten Leute Geburtstag haben.

Kann jmd helfen?


LG

CS

Betrifft: AW: So gehts z.B.
von: Dieter(Drummer)
Geschrieben am: 25.01.2020 11:26:11

Hallo Christoph,

evtl. kannst Du damit etwas anfangen: https://www.herber.de/bbs/user/134696.xlsm
Gruß, Dieter(Drummer)

Betrifft: AW: Häufigstes Vorkommen
von: Pierre
Geschrieben am: 25.01.2020 11:32:50

Hallo Christoph,

=MODUS.EINF()
Oder =Modalwert()

Gruß Pierre

Betrifft: AW: MODALWERT() allein reicht nur dann, ...
von: neopa C
Geschrieben am: 25.01.2020 11:55:48

Hallo Pierre,

... wenn wirklich der identische Geburtstag gesucht ist. Aber auch dann kann es sein, dass an verschiedenen Tagen die gleiche Anzahl Geburtstag haben.

Aber wahrscheinlicher ist es sowiso, dass der Tag gesucht ist (also mit unterschiedlichen Geburtsjahren).

Dafür hätte ich auch eine Formel ohne Hilfsspalte. Doch die Lösung mit Hilfsspalte, wie sie Ralf aufgezeigt hat ist einfacher.

Gruß Werner
.. , - ...

Betrifft: AW: MODALWERT() allein reicht nur dann, ...
von: Pierre
Geschrieben am: 25.01.2020 12:12:02

Hallo Werner,

Wahrscheinlich habe ich das falsch verstanden (bzgl. dem tatsächlichen Tag unabhängig des Jahres), bzw. etwas zu einfach gedacht.

Natürlich hast du damit Recht, dass die einfache Formel nur dann funktioniert.

Gruß Pierre

Betrifft: AW: Häufigstes Vorkommen
von: RPP63
Geschrieben am: 25.01.2020 11:33:33

Moin!
Zunächst mal brauchst Du eine Hilfsspalte mit =TEXT(Geburtsdatum;"TT. MMM")
Diese kopierst Du und fügst sie an beliebiger Stelle als Wert ein.
Auf diese wendest Du Daten, Duplikate entfernen an.
Daneben dann =ZÄHLENWENN(Hilfsspalte, Unikat)
Diese Formelspalte kannst Du dann absteigend sortieren.

 ABCDE
1GeburtsdatumGeburtstag GeburtstagHäufigkeit
202.02.198902. Feb 03. Feb2
303.02.199003. Feb 02. Feb1
403.02.200203. Feb   

ZelleFormel
B2=TEXT(A2;"TT. MMM")
E2=ZÄHLENWENN(B:B;D2)


Gruß Ralf

Betrifft: noch einfacher
von: RPP63
Geschrieben am: 25.01.2020 12:07:47

  • Irgendeine Zelle aus A:B markieren.

  • Einfügen, Pivot-Table

  • Geburtstag in Zeilen und Werte ziehen

  • Anzahl von Geburtstag absteigend sortieren

  • Fettich, dauert weniger als zehn Sekunden …

    Betrifft: AW: Häufigstes Vorkommen
    von: Christoph Sattler
    Geschrieben am: 26.01.2020 14:08:13

    Hallo ,
    vielen Dank für eure Hilfe.

    Klappt wunderbar!

    CS

    Beiträge aus dem Excel-Forum zum Thema "Häufigstes Vorkommen"