Microsoft Excel

Herbers Excel/VBA-Archiv

Referenzieren auf Überschrift

Betrifft: Referenzieren auf Überschrift von: Maris
Geschrieben am: 05.08.2020 11:47:54

Hallo,

Werner war so freundlich mir mit einer Formel weiterzuhelfen. Leider kann ich den Thread nicht mehr öffnen und weiter bearbeiten. Die Formel ist folgende:

=WENN(ZEILE()>ANZAHL2(INDEX('Tabelle A'!A:ZZ;;VERGLEICH(A$1;'Tabelle A'!$1:$1;0)));"";  INDEX('Tabelle A'!A:ZZ;ZEILE();VERGLEICH(A$1;'Tabelle A'!$1:$1;0))) 
Mit dieser Formel soll in einem Tabellenblatt die Überschrift aus einem anderen Tabellenblatt gefunden werden und dann die darunterliegenden Werte ausgegeben werden, wenn man die Formel runter kopiert.

Leider klappt das bei mir noch nicht, weil die Werte nicht in der zweiten Zeile anfangen und die Daten aus den Spalten nicht direkt beieinanderliegen. Die Beispieldatei zeigt das Problem:

https://www.herber.de/bbs/user/139477.xlsx

Vielleicht kann mir noch jemand helfen.

LG
Maris

Betrifft: AW: Referenzieren auf Überschrift
von: SF
Geschrieben am: 05.08.2020 11:57:39

Hola,
=WENNFEHLER(WVERWEIS(A$1;'Tabelle A'!$E$4:$N$7;ZEILE(A2);0);"")

Gruß,
steve1da

Betrifft: AW: Referenzieren auf Überschrift
von: Maris
Geschrieben am: 05.08.2020 12:55:23

Das funktioniert jetzt prima! Danke dir.

Betrifft: AW: könnte so evtl. unerwünschte Effekte haben ...
von: neopa C
Geschrieben am: 05.08.2020 14:16:36

Hallo Maris,

... wenn Du z.B. den Auswertungsbereich zu groß wählst oder unterschiedliche Anzahl an Werten je "Modell" hast könnten unerwünschte 0en erzeugt werden oder Du musst den Datenbereich immer anpassen, wenn Du Datenliste nicht als "intelligente" Tabelle formatierst und Datenerweiterungen vornehmen willst.

Deshalb würde ich eine kleine Formelerweiterung vorschlagen und zwar so:
=WENNFEHLER((WVERWEIS(A$1;'Tabelle A'!$E$4:$N99;ZEILE();0)&"")+0;"")

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "Referenzieren auf Überschrift"