Microsoft Excel

Herbers Excel/VBA-Archiv

Verweis aus Spalten

Betrifft: Verweis aus Spalten von: Nils
Geschrieben am: 14.09.2020 16:42:17


Hallo zusammen,

aus einer Gesamtübersicht (Tab. „Preiskategorien“) soll für einen bestimmten Artikel UND eine spezifische Preisgruppe der Preis abgeleitet werden (Tab. “Preisliste“).

https://www.herber.de/bbs/user/140223.xlsx

Die zusammengehörigen Datensätze sind in beiden Tabellenblättern gelb hervorgehoben.

Leider sind die Datensätze im Tab „Preiskategorien“ zumindest meines Wissens nicht ohne Weiteres mit einem SVERWEIS zuzuordnen, da die Preisgruppenpreise nicht als einzelne Datensätze, sondern in einer Zeile mit horizontal angeordneten Preisgruppenpreisen dargestellt werden.

Ich finde leider keinen Weg, auf Basis der Preisgruppe als Suchkriterium, im exemplarischen Falle „HOSP_DE“, die zugehörigen Preise zu matchen.

Hat jemand eine Idee, wie man das lösen kann? Ich habe aus Eigenrecherche abgeleitet die Vermutung, dass man das mit „Entpivotisieren“ via Power Query angehen könnte?

Danke vorab und viele Grüße

Nils

Betrifft: AW: Verweis aus Spalten
von: Hajo_Zi
Geschrieben am: 14.09.2020 16:44:20

Hallo Nils,

http://hajo-excel.de/gepackt/ohne_vba/matrix.htm

Falls Link nicht ausgeführt wird:
1. Link kopieren
2. rechte Maustaste neues Fenter.
3. Umschaltstaste drücken und Klick auf den Link

GrußformelHomepage

Betrifft: AW: Verweis aus Spalten
von: SF
Geschrieben am: 14.09.2020 16:51:31

Hola,
=SVERWEIS(A2;Preiskategorien!A1:G2;VERGLEICH(C2;Preiskategorien!A1:G1;0);0)

Gruß,
steve1da

Betrifft: AW: Verweis aus Spalten
von: Nils
Geschrieben am: 14.09.2020 17:02:30

...perfekt - so einfach kann es gehen!

Danke und viele Grüße

Nils

Beiträge aus dem Excel-Forum zum Thema "Verweis aus Spalten"