Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema TextBox
BildScreenshot zu TextBox TextBox-Seite mit Beispielarbeitsmappe aufrufen

dynamischer Hyperlink

Betrifft: dynamischer Hyperlink von: Philipp
Geschrieben am: 14.09.2020 20:27:22

Hallo zusammen

Ich kann ja via Hyperlink einen Link auf eine bestimmte Zelle machen. Meine Frage, kann ich das irgendwie dynamischer machen? Ich habe folgendes Problem


Ich habe ein Tabellenblatt Artikelverwaltung auf dem ein Hyperlink auf das Tabellenblatt Lieferanten in die entsprechende Zelle verweist. Wird die Tabelle der Lieferanten irgendwie sortiert oder umgestellt, funktioniert der Hyperlink leider nicht mehr.


mir schwebt folgendes vor: Wenn ich den hyperlink auf dem Tabellenblatt Artikelverwaltung anklicke, soll er mir den Lieferanten nach seinem Namen suchen und nicht fest auf eine Zelle verweisen, also dynamischer werden.

Leider bin ich kein Formelspezi, aber müsste wohl etwas mit den Funktionnen Vergleich und Hyperlink sein.


Ich hoffe ich habe mich klar und verständlich ausdrücken können, ansonsten einfach fragen.


Betrifft: AW: dynamischer Hyperlink
von: hary
Geschrieben am: 15.09.2020 07:58:48

Moin
Da du nicht geschrieben hast wo/was steht.



Lieferanten
 AB
1ArtikelLieferant
2MutterBert
3ScheibeAnton
4SchraubeMike
5  
6  

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit





Artikelverwaltung
 AB
1Scheibegehe zu

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
B1=WENNFEHLER(HYPERLINK("#Lieferanten!"&ADRESSE(VERGLEICH(A1;Lieferanten!A:A;0);2);"gehe zu");"Artikel nicht gefunden")  =IFERROR(HYPERLINK("#Lieferanten!"&ADDRESS(MATCH(RC[-1],Lieferanten!C[-1],0),2),"gehe zu"),"Artikel nicht gefunden")

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary

Beiträge aus dem Excel-Forum zum Thema "dynamischer Hyperlink"