Microsoft Excel

Herbers Excel/VBA-Archiv

Div. Suchvorgaben über Aggregatfunktion

Betrifft: Div. Suchvorgaben über Aggregatfunktion von: Jan
Geschrieben am: 21.09.2020 17:05:57

Hey zusammen,

ich habe für eine Übersicht über versch. Produkte mit diversen Produkteigenschaften (Reiter "Produktmatrix") eine Suchmaske mit Hilfe der Aggregat-Funktion erstellt.

Ich möchte eine Mehrfachauswahl im Reiter "Selektion" zur Verfügung stellen. Im Reiter "Ergebnis" soll dann eine Übersicht der Auswahl erfolgen und die Produkte ausgeworfen werden, die sich durch die Vorauswahl in Reiter "Selektion" ergeben (siehe 'Ergebnis'!B12:'Ergebnis'!B31).

Folgende Sachen sollen funktionieren:
- Ergebnisausgabe ab 'Ergebnis'!B12 auch wenn Selektionsmöglichkeiten im Reiter 'Selektion' ausgelassen wurden
- Mehrfachauswahl soll auch bei mehreren Selektionen (z.B. nach Eingabe von "x" in 'Selektion'!B6, 'Selektion'!B7 und 'Selektion'!B8) soll die Suche via ODER-Intelligenz in Frage kommende Ergebnisse im Reiter "Ergebnis" ab 'Ergebnis'!C12 ausspucken
- optional: Egal, in welcher Zeile die Produkte mit ihren Eigenschaften im Reiter "Produktmatrix" gepflegt sind, sobald sie das erstmögliche Ergebnis nach Selektion der Kreiterien sind, sollen sie auch ab 'Ergebnis'!B12 bzw. 'Ergebnis'!C12 stehen.

Anbei der Dateilink: https://www.herber.de/bbs/user/140357.xlsx

Liebe Grüße,
Jan

Betrifft: AW: offensichtlich hast Du Office365 im Einsatz...
von: neopa C
Geschrieben am: 21.09.2020 17:55:19

Hallo Jan,

... die Version mit den neuen Funktionen hab ich nicht. Aber eine Lösung wäre sicher auch ohne dies möglich, nur eben evtl. etwas aufwendiger.

Hier mein Formelvorschlag für B12, für den Fall dass sich in B4 ein ="" ergibt, weil keine Auswahl zu dieser Kategorie im Tabellenblatt Selektion getroffen wurde.

Analog kannst Du die Formelteile für die anderen Kategorien anpassen, wenn sich dort auch ein ="" ergibt.

=WENNFEHLER(INDEX(Produktmatrix!$B:$B;AGGREGAT(15;6;ZEILE(Produktmatrix!$B$3:$B$99)/ZÄHLENWENN(Produktmatrix!$A$3:$A$99;WENN(B$4="";"?*";B$4))^0/(Produktmatrix!$D$3:$D$99=B$6)/(Produktmatrix!$E$3:$E$99=B$8)/(Produktmatrix!$H$3:$H$99=B$10)+(Produktmatrix!$I$3:$I$99=B$10);ZEILE()-11));"")

Gruß Werner
.. , - ...