Microsoft Excel

Herbers Excel/VBA-Archiv

Matrix-Formel zur Summierung MIN

Betrifft: Matrix-Formel zur Summierung MIN von: Mikael
Geschrieben am: 22.09.2020 21:59:50

Vorbemerkung: dies ist ein konstruiertes, vereinfachtes Beispiel des Problems, das in dieser Form auch leicht ohne Matrixformeln gelöst werden kann. Die eigentliche Anwendung ist komplexer und ich brauche dort die Matrixformel.

Ich habe eine 3spaltige Tabelle mit Zahlenwerten. Ich möchte in einer einzigen Zelle mithilfe einer Matrixformel die Gesamtsumme der MIN-Werte jeder Zeile berechnen. Ich finde jedoch keinen Weg, wie ich in einer einzigen Matrix-Formel zunächst zeilenweise das Minimum berechnen und dann das Ergebnis aller MIN-Berechnungen aufsummieren kann.

Beispiel (https://www.herber.de/bbs/user/140375.xlsx):

Werte sind in den Zellen A3:C8. Die Matrixformel soll zeilenweise das Minimum berechnen, also sinngemäß:

=SUM(MIN(A3:C3);MIN(A4:C4);MIN(A5:C5);MIN(A6:C6);MIN(A7:C7);MIN(A8:C8))

Ich möchte im Prinzip etwas in folgender Form machen:

{=SUM(MIN(A3:C3):MIN(A8:C8))}

aber natürlich funktioniert es in dieser Form nicht.

Für Input bin ich sehr dankbar!

Herzlich, Mikael

Betrifft: AW: Matrix-Formel zur Summierung MIN
von: Werni
Geschrieben am: 23.09.2020 04:25:48

Hallo Mikael
Private Sub Worksheet_Change(ByVal Target As Range)
    Dim i As Integer, j As Integer
    If Intersect(Target, Range("B3:D99")) Is Nothing Then Exit Sub
        j = 0
            For i = 3 To Range("B100").End(xlUp).Row
                j = j + WorksheetFunction.Min(Range(Cells(i, 2), Cells(i, 4)))
            Next
        [H1] = j
End Sub
Gruss Werni

Betrifft: AW: Matrix-Formel zur Summierung MIN
von: Mikael
Geschrieben am: 23.09.2020 08:49:39

Hallo Werni,
danke für den VBA-Lösungsvorschlag. Ich frage mich aber, ob das nicht auch ohne VBA geht. Weiß jemand, wie das funktionieren könnte?
Herzlich, Mikael

Betrifft: AW: Matrix-Formel zur Summierung MIN
von: Günther
Geschrieben am: 23.09.2020 11:09:52

Moin Mikael,
ja, es geht auch ohne VBA.
Aber da ich auch keine Matrix-Formel verwende (sondern Power Query) fällt das wohl auch raus…
 
Gruß
Günther  |  mein Excel-Blog

Betrifft: AW: ja, geht mit Formel ohne ohne VBA ...
von: neopa C
Geschrieben am: 23.09.2020 11:19:49

Hallo Mikael,

... so: =SUMMENPRODUKT(TEILERGEBNIS(5;BEREICH.VERSCHIEBEN(B3:D3;ZEILE(B1:B9)-1;;;)))

Gruß Werner
.. , - ...

Betrifft: AW: ja, geht mit Formel ohne ohne VBA ...
von: Mikael
Geschrieben am: 23.09.2020 15:36:47

Danke, Werner! Ich bin platt. 30 Jahre Excel und nicht selber drauf gekommen! :-)

Betrifft: AW: bitteschön owT
von: neopa C
Geschrieben am: 23.09.2020 15:41:18

Gruß Werner
.. , - ...

Betrifft: hättest nur kugeln müssen
von: WF
Geschrieben am: 23.09.2020 15:56:08

das ist unsere alte Formel:
https://www.herber.de/excelformeln/pages/die_Summe_der_Zeilenmaxima_bilden.html

Da lediglich mit Maximum (4) statt Minimum (5)

WF

Beiträge aus dem Excel-Forum zum Thema "Matrix-Formel zur Summierung MIN"