Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema RefEdit
BildScreenshot zu RefEdit RefEdit-Seite mit Beispielarbeitsmappe aufrufen

mehrere Zeilen im Bereich durchsuchen

Betrifft: mehrere Zeilen im Bereich durchsuchen von: Matt
Geschrieben am: 24.09.2020 14:06:03

Hallo,

ich grüble seit geraumer Zeit an folgendem Problem und finde auch nach langer Suche und nach unzähliegen Basteleien keine Lösung.
In einer Datei befindet sich in Zeile 1 das Datum des jeweiligen Tages von 01.01.-31.12 über die Spalten von B bis ND verteilt.
In Spalte A befinden sich von Zeile 2 bis Zeile 338 die Namen der Mitarbeiter; in den folgenden Spalten u. a. mitunter ein 'K' für krank.
Ich bin nun auf der Suche nach einer Formel, die mir diejenigen Mitarbeiter ausgibt, die in einem Zeitraum aus Datum1 und Datum2 mehr als 40mal mit 'K' vermerkt sind.
In sämtliche Index-, Vergleich- und Summenprodukt-Formeln ist mittlerweile ein dicker Knoten gekommen, sodass ich hier nicht mehr weiter weiß.
Vielleicht findet sich ja eine (Teil-)Lösung, das wäre ein Traum.

Vielen Dank schonmal,
Matt

Betrifft: AW: mehrere Zeilen im Bereich durchsuchen
von: Hajo_Zi
Geschrieben am: 24.09.2020 14:56:32

Hallo Matt,

frage jemand der neben Dir sitzt der sieht die Datei.
Die meisten hier sehen Sie nicht.
Da Sie nicht auf Deinen Rechner schauen.
Vielleicht sollte die Datei verlinkt werden?

Benutze hier im Forum die Funktion zum hochladen. Falls Du die nicht benutzen möchtest beachte, von unsicheren Servern wie z.B. www.file-upload.net lade ich keine Datei runter. (lt. Einschätzung meines Virenprogramms)

Das ist nur meine Meinung zu dem Thema.

GrußformelHomepage

Betrifft: AW: mehrere Zeilen im Bereich durchsuchen
von: JoWE
Geschrieben am: 24.09.2020 20:06:27

Hallo Matt,
versuchs mal so:
in NE1 Startdatum Auswertezeitraum z.B. "01.03.2020"
in NF1 Endedatum Auswertezeitraum z.B. "31.10.2020"
in NG1 "K-Tage"
in NG2 Formel: =ZÄHLENWENNS($B$1:$ND$1;">="&$NE$1;$B$1:$ND$1;"<="&$NF$1;B3:ND3;"k")
die Formel bis Zeile 338 runterkopieren
Dann das Autofilter für den Bereich A1:NG338 setzten
und in der Spalte NG nach ">40" filtern

Gruß
Jochen

Betrifft: AW: kleine Änderung...
von: JoWE
Geschrieben am: 24.09.2020 20:10:10

in NG2 Formel: =ZÄHLENWENNS($B$1:$ND$1;">="&$NE$1;$B$1:$ND$1;"<="&$NF$1;B2:ND2;"k")

Betrifft: AW: kleine Änderung...
von: JoWE
Geschrieben am: 24.09.2020 20:10:10

in NG2 Formel: =ZÄHLENWENNS($B$1:$ND$1;">="&$NE$1;$B$1:$ND$1;"<="&$NF$1;B2:ND2;"k")

Betrifft: AW: kleine Änderung...
von: Matt
Geschrieben am: 25.09.2020 14:20:00

Hallo Jochen,

bin Dir sehr dankbar für Deine Unterstützung, das hilft mir enorm weiter. Jetzt kann ich mir alle über 40 anzeigen lassen und muss die nur noch in eine Liste packen.

Tausend Dank nochmal und ein sehr schönes Wochenende,
Matt

Beiträge aus dem Excel-Forum zum Thema "mehrere Zeilen im Bereich durchsuchen"