Microsoft Excel

Herbers Excel/VBA-Archiv

Index/Vergleich Anwendungsproblem

Betrifft: Index/Vergleich Anwendungsproblem von: Hauserconsulting
Geschrieben am: 24.09.2020 15:28:25

Vielen Dank für euern Support hier in dem Forum!


Ich habe versucht über eine Kombination aus INDEX und VERGLEICH einen Wert aus Tabelle 2, Spalte K in die Tabelle 1, Spalte E einzutragen.

Dabei ist die Matrix klar, die Spalte auch und die Zeile soll über einen Vergleich definiert werden.

Leider bekomme ich nur Fehlermeldungen und kann mir nicht erklären wie ich dieses so scheinbar einfache Problem lösen kann.


In folgender Datei sind alle relevanten Spalten markiert und in Zelle E2, Tabelle 1 ist auch mein Versuch zu sehen.

https://www.herber.de/bbs/user/140413.xlsx



Ich freue mich sehr auf Antworten und bin schon gespannt auf die Lösung!

LG

Betrifft: AW: Index/Vergleich Anwendungsproblem
von: SF
Geschrieben am: 24.09.2020 15:32:23

Hola,

"Tabelle2!" ist ein TEXT, kein Bereich.
Und warum nimmst du nicht einfach einen Sverweis?
=SVERWEIS(A2;Tabelle2!F2:K10;6;0)

Gruß,
steve1da

Betrifft: AW: Index/Vergleich Anwendungsproblem
von: Hauserconsulting
Geschrieben am: 24.09.2020 15:57:47

Vielen Dank für deine schnelle Antwort, ich habe es im "großen Dokument" ausprobiert und es funktioniert noch nicht ganz aber ich werde mich etwas ausprobieren!

Betrifft: AW: die aufgezeigt SVERWEIS()-Formel ...
von: neopa C
Geschrieben am: 25.09.2020 13:04:30

Hallo,

... gibt natürlich nur in E2 einen korrektes Ergebnis aus.
Wenn Du die Formel nach unten kopieren willst, dann in E2:
=SVERWEIS(A2;Tabelle2!F:K;6;0)

und falls doch ein Suchwert nicht vorhanden sein sollte, einfach:
=WENNFEHLER(SVERWEIS(A2;Tabelle2!F:K;6;0);"")

Gruß Werner
.. , - ...

Betrifft: AW: Index/Vergleich Anwendungsproblem
von: Herbert_Grom
Geschrieben am: 24.09.2020 17:57:02

Hallo,

mit dieser Formel in E2 sollte es klappen:
=INDEX(Tabelle2!$K:$K;VERGLEICH(A2;Tabelle2!$F:$F;0))
Servus