Microsoft Excel

Herbers Excel/VBA-Archiv

Link auf variablen Dateinamen

Betrifft: Link auf variablen Dateinamen von: TiB
Geschrieben am: 24.09.2020 15:10:01

Hallo zusammen,

ich stehe (noch) vor folgendem Problem, einiges habe ich selber schon lösen können :)

Es gibt einen Button, der bei Klick die Tabelle mit Namen aus einem Zellinhalt speichert. Zum Beispiel steht in A1 "Test", dann wird die Tabelle Test.xlsx im von mir vorgegebenen Verzeichnis gespeichert. Nun habe ich in einem anderen Verzeichnis Bilder gespeichert, die vor der Erweiterung denselben Namen haben, also z.B. Test.jpg.

In M1 wird N1 auf bestimmtem Inhalt überprüft und dann ein Link mit "friendly_name" mit Verweis auf ein Verzeichnis angelegt

=WENN(N1="J";HYPERLINK("I:\Pfad";ZELLE("inhalt";A1)))

Das klappt super, ich bekomme in M1 das Wort Test (=Inhalt A1) und der Link führt mich auf das Verzeichnis.

Wie bekomme ich es aber hin, das nicht nur der Explorer mit entsprechendem Verzeichnis geöffnet wird, sondern direkt die Datei Test.jpg (Test=Inhalt aus A1)?

Besten Dank schon mal im voraus, ich habe größtes Vertrauen in euer knowhow! :)

VG, TiB

Betrifft: AW: Link auf variablen Dateinamen
von: peterk
Geschrieben am: 24.09.2020 15:18:30

Hallo

=WENN(N1="J";HYPERLINK("I:\Pfad\" & ZELLE("inhalt";A1);ZELLE("inhalt";A1)))



Betrifft: AW: Link auf variablen Dateinamen
von: TiB
Geschrieben am: 25.09.2020 07:26:14

Guten Morgen,

das probier ich aus. Danke Peter! Sehe ich das richtig, dass die Dateiendung egal ist? Es wird die Datei A1.xxx geöffnet? Sollte es A1.jpg und A1.pdf geben, was wird dann geöffnet bzw. wie gebe ich den Dateityp mit?

Betrifft: AW: Link auf variablen Dateinamen
von: peterk
Geschrieben am: 25.09.2020 09:15:26

Hallo

Wenn ZELLE("inhalt";A1) nur das Word "Test" enthält wird dein Hyperlink nicht funktionieren, da das System die Datei "I:\Pfad\Test" nicht findet (das System braucht auch den Dateityp). Entweder schreibst Du in einer eigene Spalte noch den gewünschten Dateityp und verknüpfst diesen mit einem weiteren "&", oder Du schreibst den vollen Namen und Type in deine Zelle und filterst im friendly text den Dateityp raus.

Peter

Betrifft: AW: Link auf variablen Dateinamen
von: TiB
Geschrieben am: 25.09.2020 11:17:18

Hab ne ganze Weile rumprobieren müssen und war schon kurz vor dem Verzweifeln. Was so ein nicht bedachtes "\" alles bewirken kann....

Klappt prima so, besten Dank für deine Hilfe!

TiB

Beiträge aus dem Excel-Forum zum Thema "Link auf variablen Dateinamen"