Microsoft Excel

Herbers Excel/VBA-Archiv

Tabellen Ergebnisse zusammenrechnen

Betrifft: Tabellen Ergebnisse zusammenrechnen von: Michaela S.
Geschrieben am: 25.09.2020 14:31:51

Hallo.

Ich habe wieder mal ein mir unlösbares Problem. Bin mir aber auch nicht sicher, ob es so überhaupt lösbar ist.


Ich erhalte aus einer Warenwirtschaft eine Auflistung der Umsätze von Artikeln. Das Problem ist, diese gibt es mit unterschiedlichen Artikelnummern(endungen).


Ist es irgendwie in Excel möglich, diese zu vergleichen und die Menge & Umsatz zusammen zu ziehen?


Ich habe das mal mit einem Test - Artikel angehängt.


https://www.herber.de/bbs/user/140438.xls


Im Tabellenblatt "Ergebnis" soll dann halt jeweils Die Oberartikelnummer, die Bezeichnung (ohne fba / pdv) und die Gesamtsumme der ØMenge & des ØUmsatzes erscheinen.


Wie gesagt, ich weiß leider nicht, ob das überhaupt geht, weil es keine reinen Zahlen sind.... Daher würde ich mich über Infos /


Viele Grüße,

Michaela

PS: nach nochmaligen Durchlesen:
Die Umsatztabelle enthält natürlich ca. 300 Artikel dieser Art Auflistung und manchmal gibt es nur eine Artikelnummer oder nur 2. Mal mit pdv mal ohne und mal alle 3.... :-/ Jetzt klingt es noch komplizierter :-/

Betrifft: AW: Tabellen Ergebnisse zusammenrechnen
von: Herbert_Grom
Geschrieben am: 25.09.2020 15:20:28

Hallo Michaela,

probiers mal damit: In "Ergebnis.D2":
=SUMMENPRODUKT((ISTZAHL(SUCHEN($A$2;'Umsatz Tabelle'!$A$2:$A$4;'Umsatz Tabelle'!$C$2:$C$4=$B2)) *'Umsatz Tabelle'!$D$2:$D$4)) 
Servus

Betrifft: AW: Tabellen Ergebnisse zusammenrechnen
von: Günther
Geschrieben am: 25.09.2020 15:27:56

Moin Michaela,
vorweg ein Tipp: Für mich ist bei der Angabe deiner Version "2016" die Dateiendung ".xls" ein Grund, das File nicht zu öffnen. So lässt sich prima verschleiern, dass dort (eventuell) VBA enthalten ist.

Und wenn die eigentlichen Artikelnummern immer die gleiche Länge haben dann sollte das beispielsweise im ersten Schritt mit LINKS() ein guter erster Schritt sein.
 
Gruß
Günther  |  mein Excel-Blog

Betrifft: AW: Tabellen Ergebnisse zusammenrechnen
von: Herbert_Grom
Geschrieben am: 25.09.2020 15:26:19

Und in C2:
=SUMMENPRODUKT((ISTZAHL(SUCHEN($A$2;'Umsatz Tabelle'!$A$2:$A$4;'Umsatz Tabelle'!$C$2:$C$4=$B2)) *'Umsatz Tabelle'!$G$2:$G$4)) 
Servus

Betrifft: AW: Tabellen Ergebnisse zusammenrechnen
von: fcs
Geschrieben am: 25.09.2020 15:35:03

Hallo Michaela,

damit die Daten entsprechend ausgewertet werden können müssen die Daten in Umsätze zunächst aufbereitet werden.
Kann man hier per Formel in weiteren Spalten machen - ginge natürlich auch per Makro.
In jeder Zeile muss die Ober-Artikelnummer vorhanden sein. Die als Texte vorhandenen Zahlenwerte müssen in Zahlen umgewandelt werden.

Diese Daten kann man dann per sogenanntem Pivottabellenbericht auswerten.

https://www.herber.de/bbs/user/140439.xls

LG
Franz

Betrifft: AW: Tabellen Ergebnisse zusammenrechnen
von: Herbert_Grom
Geschrieben am: 25.09.2020 15:40:04

Hallo Franz,

schau dir doch mal meine Formel an, die braucht nix dazu, auch keine Zahlenumwandlung! Nur die blöden Blanks vor der "1000216" muss sie raus machen!

Servus

Betrifft: AW: Tabellen Ergebnisse zusammenrechnen
von: Herbert_Grom
Geschrieben am: 25.09.2020 15:47:04

Hallo Michaela,

hier mal deine AM: https://www.herber.de/bbs/user/140441.xlsx

Servus

Beiträge aus dem Excel-Forum zum Thema "Tabellen Ergebnisse zusammenrechnen"