Microsoft Excel

Herbers Excel/VBA-Archiv

Summenprodukt mit Datumsgrenzen

Betrifft: Summenprodukt mit Datumsgrenzen von: Burghard
Geschrieben am: 09.10.2020 21:53:01

Hallo,

ich brauche mal Hilfe. Bei der unteren Formel erhalte ich #NV als Ergebnis.

=SUMMENPRODUKT(($A$2:$A72>=2019)*($H$2:$H388="xx")*($A$2:$A72<=2020);$F$2:$F388)

Im Bereich A2 bis A72 stehen jeweils Tages-Datumswerte mehrerer Jahre (2017 bis 2020). Ich möchte das Ergebnis nur auf alle Einträge bzw. Geldbeträge im Jahr 2019 eingrenzen.
Im Bereich H2 bis H388 stehen in Zellen Markierungen (xx).
Im Bereich F2 bis F388 stehen in den Zellen Geldbeträge.

Hilfe wäre nett.

Grüße
Burghard

Betrifft: Tages-Datumswerte sind größer 40.000
von: WF
Geschrieben am: 09.10.2020 22:13:04

Hi,

und die Bereiche müssen identisch sein: 2 bis 72

=SUMMENPRODUKT((JAHR($A$2:$A72)>=2019)*($H$2:$H72="xx")*(JAHR($A$2:$A72)<=2020);$F$2:$F72)

Salut WF

Betrifft: und "nur 2019" macht's einfacher
von: WF
Geschrieben am: 09.10.2020 22:30:14

=SUMMENPRODUKT((JAHR($A$2:$A72)=2019)*($H$2:$H72="xx");$F$2:$F72)

WF

Betrifft: AW: Richtiger Tipp
von: Burghard
Geschrieben am: 10.10.2020 17:26:10


Hallo WF,

ich bin ein Trottel. Hätte den Fehler sehen müssen. Danke für die Tipps und noch ein schönes WE!

Grüße
Burghard