Microsoft Excel

Herbers Excel/VBA-Archiv

Anpassung von Formeln nach Dropdown-Ausw

Betrifft: Anpassung von Formeln nach Dropdown-Ausw von: harti
Geschrieben am: 10.10.2020 10:19:31

Hallo und guten Morgen zusammen,

nachdem mir hier gestern Abend superschnell geholfen werden konnte habe ich die Hoffnung, dass auch bei meinem zweiten Problem jemand die Lösung weiß.

Ich habe eine Datei mit mehreren Tabellenblättern (2021, 2022, 2023 usw.). Diese werden in den nächsten Jahren mit Daten gefüllt.
Im Tabellenblatt auswertungen gibt es für Auswertungen Formeln in den Feldern D4:D6 und E6.
Die Berechnungen sind abhängig von den Feldern C4:C6. Dort kann man per Dropdown-Menü verschiedene Optionen auswählen.

Jetzt zum Problem. Die Formeln beinhalten alle das Tabellenblatt 2021.
Nun sollen die Formeln automatisch angepasst werden wenn im Feld C3 z.B. das Jahr 2022 ausgewählt wird.
Dann sollen sich die Formeln natürlich auf das Tabellenblatt 2022 beziehen usw.

Ich habe schon gegoogelt...aber eine Lösung hierfür habe ich nirgends gefunden.

Ist das überhaupt lösbar?

Ich bin dankbar für jeden Hinweis oder für jede Lösung :-)

Danke...
tobi

https://www.herber.de/bbs/user/140774.xlsm

Betrifft: AW: Anpassung von Formeln nach Dropdown-Ausw
von: Hajo_Zi
Geschrieben am: 10.10.2020 10:23:52

Hallo Tobi,

benutze Indirekt
=Indirekt(C3 &"!A23)
mal nur als Beispiel. Datei nicht angesehen.

GrußformelHomepage

Betrifft: AW: Anpassung von Formeln nach Dropdown-Ausw
von: harti
Geschrieben am: 10.10.2020 10:39:10

Hallo Hajo,

vielen Dank für die schnelle Rückmeldung und Deinen Lösungsansatz.

Ich bekomme es aber nicht richtig hin den Indirekt-Ansatz in meine Formel unterzubekommen.

Formel lautet: =ZÄHLENWENN('2021'!D11:D5010;auswertungen!C4)

Da wo jetzt '2021' steht muss ja Indirekt(C3 stehen...nur bekomme ich das Formelgewulst nicht richtig zusammen :-)

Betrifft: AW: Anpassung von Formeln nach Dropdown-Ausw
von: Hajo_Zi
Geschrieben am: 10.10.2020 10:45:31

wie von mir vorgheschlagen.

ZÄHLENWENN(Indirekt(C3 &"'!D11:D5010");auswertungen!C4)


Gruß Hajo

Betrifft: AW: Anpassung von Formeln nach Dropdown-Ausw
von: harti
Geschrieben am: 10.10.2020 10:48:50

Ja...habe es jetzt so gemacht, erhalte aber einen #BEZUG Fehler...

Betrifft: AW: Anpassung von Formeln nach Dropdown-Ausw
von: Hajo_Zi
Geschrieben am: 10.10.2020 10:50:31

Zu Deiner Datei kann ich nichts schreiben, was wohl daran liegt das ich nicht auf fremde Rechner schaue.Ich baue keine Datei nach.

Sollte die Datei verlinkt werden?

Wenn du an Stelle einer Demomappe deine Originalmappe hochladen willst, diese aber sensible Daten enthält, kannst du diese Daten
http://www.ms-office-forum.de/forum/showthread.php?t=322895
änderrn.

Bilder lade ich mir nicht runter, da Excel damit nichts anfangen kann.

http://www.excel-ist-sexy.de/bilder-statt-datei/

Hochgeladene Bilder können zwar als solche in Excel importiert werden, sind jedoch bei der Lösung von Problemen nicht sehr hilfreich, da man die eigentlichen Daten nicht ohne große und zeitraubende Umwege direkt in die Tabelle übertragen kann.

Das ist nur meine Meinung zu dem Thema.

keine Ahnung welche Zelle.

Gruß Hajo

Betrifft: AW: Anpassung von Formeln nach Dropdown-Ausw
von: harti
Geschrieben am: 10.10.2020 11:00:14

Meine Datei hatte ich im ersten Post bereits verlinkt


https://www.herber.de/bbs/user/140774.xlsm

Betrifft: AW: Anpassung von Formeln nach Dropdown-Ausw
von: Hajo_Zi
Geschrieben am: 10.10.2020 11:02:30

Im ersten Beitrag vemute ich ist Deine geänderte Formel nicht eingetragen.
Gut die Zelle möchtest Du nicht mitteilen.
Ich bin dann raus.
Viel Erfolg noch.

Gruß Hajo

Betrifft: AW: Anpassung von Formeln nach Dropdown-Ausw
von: harti
Geschrieben am: 10.10.2020 11:07:50

Hier die Datei mit der geänderten Formel, also dem INDIREKT-Zusatz.
Befindet sich in Blatt Auswertungen in Zelle D4.

https://www.herber.de/bbs/user/140775.xlsm

Betrifft: AW: z.B. mit INDIREKT() in Z1S1 Schreibweise ...
von: neopa C
Geschrieben am: 10.10.2020 12:05:45

Hallo tobi,

... mit nur einer Formel unter der Annahme, dass die Überschriften immer in Zeile 10 stehen in D4:

=ZÄHLENWENN(INDIREKT("'"&C$3&"'!Z11S"&VERGLEICH(B4&"*";INDIREKT("'"&C$3&"'!A10:Z10");0) &":Z5010S"&VERGLEICH(B4&"*";INDIREKT("'"&C$3&"'!A10:Z10");0);0);auswertungen!C4)


und diese Formel nach unten kopieren.

Die "inneren" INDIREKT()-Formelteile können durch eine Direktbezug auf ein Tabellenblatt ersetzt werden, wenn auch die Spaltenstruktur immer gleich ist.

Gruß Werner
.. , - ...

Betrifft: AW: z.B. mit INDIREKT() in Z1S1 Schreibweise ...
von: harti
Geschrieben am: 10.10.2020 12:13:37

Hallo Werner,

vielen Dank für Deine Hilfe. Deine Formel funktioniert perfekt.

Habe mittlerweile aber auch schon den Fehler entdeckt warum bei mir der #BEZUG Fehler kam.

Der Vorschlag von Hajo lautete: ZÄHLENWENN(Indirekt(C3 &"'!D11:D5010");auswertungen!C4)

Mit ZÄHLENWENN(INDIREKT(C3 &"!D11:D5010");auswertungen!C4) klappt's jetzt. Es lag am ' in Hajos Formel...ohne dem funktioniert's.

Schönes Wochenende wünsche ich Dir...
tobi

Betrifft: AW: danke, wünsch ich Dir auch owT
von: neopa C
Geschrieben am: 10.10.2020 12:30:15

Gruß Werner
.. , - ...

Betrifft: Hajo hatte geschlampt u.führendes "'"& vergessen!
von: Luc:?
Geschrieben am: 10.10.2020 20:17:35

Gruß, Luc :-?

Betrifft: INDIREKT in Z1S1-Form
von: Luc:?
Geschrieben am: 10.10.2020 20:13:42

Du weißt doch, Werner,
dass INDIREKT in Z1S1-Form nicht internationalisierbar ist, weil die Angabe Text ist und somit nicht automatisch gewandelt wird. Zahlenwerte kann man auch in die ADRESSE-Fkt einsetzen und deren Ergebnis kann stets umgewandelt wdn, egal ob A1- oder Z1S1-Form dabei rauskommt.
Gruß + schöSo, Luc :-?

Betrifft: AW: war aber hier auch ohne ausreichend owT
von: neopa C
Geschrieben am: 12.10.2020 09:07:27

Gruß Werner
.. , - ...

Betrifft: Tja, wenn's national bleibt...! owT
von: Luc:?
Geschrieben am: 12.10.2020 19:33:02

:-?