Microsoft Excel

Herbers Excel/VBA-Archiv

WENN(ODER)

Betrifft: WENN(ODER) von: Qualitätsmensch
Geschrieben am: 13.10.2020 09:07:00

Hallo zusammen,


ich habe folgende Formel:=WENN(ODER(B24<>"";C24<>"";A24<HEUTE()+365);EDATUM(A24;1);"")

Nun möchte ich die anzusprechenden Zellen erweitern, d. h. ich möchte die Zellen B24:Q24 mit einbeziehen. Gibt es eine Möglichkeit dies zu tun ohne jede Zelle einzeln in der Formel anzusprechen? Bei B24:Q24<>"" bekomme ich die Fehlermeldung #WERT!


Vielen Dank im Voraus!


Grüße


Qualitätsmensch

Betrifft: AW: WENN(ODER)
von: SF
Geschrieben am: 13.10.2020 09:16:00

Hola,

ungetestet:
=WENN(ODER(ZÄHLENWENN(B24:Q24;"<>");A24
Gruß,
steve1da

Betrifft: AW: WENN(ODER)
von: Qualitätsmensch
Geschrieben am: 13.10.2020 09:44:02

Hallo steve1da,

zunächst Danke für die schnelle Rückmeldung!

=WENN(ODER(ZÄHLENWENN(B24:Q24;"<>");A24<HEUTE()+365);EDATUM(A24;1);"")

Das hat wunderbar geklappt! Vielen Dank!

Gruß

Qualitätsmensch