Microsoft Excel

Herbers Excel/VBA-Archiv

Werte addieren wenn...

Betrifft: Werte addieren wenn... von: Franz W.
Geschrieben am: 22.10.2020 12:20:59

Hallo Fachleute,

ich möchte Werte addieren, die zu einem bestimmten Jahr gehören:

in Spalte A stehen Datümer, in Spalte D stehen Werte

Spalte A     Spalte D
03.09.2019     10
05.09.2019     20
11.09.2019     30
03.09.2020     40
05.09.2020     50
11.09.2020     60
20.09.2020     70

Es sollen nun z. B. die Werte aus dem Jahr 2019 addiert werden: gewünschtes Ergebnis also 60.

Geht das mit Summewenn? Ich finde es nicht raus. Oder muss es eine andere Formel sein? Dafür bitte ich um eure Hilfe.

Danke schonmal und Grüße
Franz

Betrifft: AW: Werte addieren wenn...
von: SF
Geschrieben am: 22.10.2020 12:24:47

Hola,
=summenprodukt((jahr(A2:A10)=2019)*(B2:B10))

Gruß,
steve1da

Betrifft: AW: Werte addieren wenn...
von: Franz W.
Geschrieben am: 22.10.2020 12:37:26

Super Steve,

danke erstmal, das funktioniert so.

Lässt sich das jetzt auch noch dynamisch gestalten? Wenn also nach A10 noch weitere Werte dazu kommen, die von der Formel brücksichtigt werden sollen?

Oder anders: der Gesamtbereich geht über A10/D10 hinaus, z. B. bis a100/d100, ist aber noch nicht mit Werten gefüllt. Nehme ich aber in deiner Formel das mit rein:
=summenprodukt((jahr(A2:A100)=2019)*(D2:D100))
dann gibt's ne Fehlermeldung.

Lässt sich das auch noch integrieren?

Grüße
Franz

Betrifft: AW: Werte addieren wenn...
von: SF
Geschrieben am: 22.10.2020 12:40:20

dann gibt's ne Fehlermeldung.
Verrätst du uns auch welche? Wenn #WERT erscheint sind die Zellen sehr wohl gefüllt und zwar mit Text.

Betrifft: Fehlermeldung ist #NV - aber mein Fehler
von: Franz W.
Geschrieben am: 22.10.2020 12:49:21

.... ich hab's rausgefunden: Es sind Überträge aus anderen Bereichen, und zwar mit Formeln.

Übernehme ich Deine Formel, auch erweitert, für die Originaltabelle, dann stimmt sie - mein Fehler!

Danke Steve und Grüße
Franz

Betrifft: AW: nicht mit SUMMEWENN() aber mit SUMMEWENNS()...
von: neopa C
Geschrieben am: 22.10.2020 12:36:46

Hallo Franz.

... z.B. so: =SUMMEWENNS(B:B;A:A;">="&"1.1.19"+0;A:A;"<"&"1.1.20"+0)

Gruß Werner
.. , - ...

Betrifft: AW: nicht mit SUMMEWENN() aber mit SUMMEWENNS()...
von: Franz W.
Geschrieben am: 22.10.2020 12:38:57

Danke Werner,

aber das kann mein Excel noch nicht :-((

Grüße
Franz

Betrifft: AW: dann ...
von: neopa C
Geschrieben am: 22.10.2020 12:45:12

Hallo Franz,

... folgende Formel:
=SUMMENPRODUKT((JAHR(A2:A100)=2019)*1;D2:D100)

vorausgesetzt in Spalte A stehen nur Datumswerte oder die Zellen sind leer.

Gruß Werner
.. , - ...

Betrifft: AW: dann ...
von: Franz W.
Geschrieben am: 22.10.2020 12:52:40

Hallo Neopa,

was macht das "*1" in deiner Formel? Das kommt in Steves Formel nicht vor, bringen aber beide dasselbe Ergebenis.....

Fragt
Franz

Betrifft: AW: de entscheidende Unterschied ist ...
von: neopa C
Geschrieben am: 22.10.2020 13:27:37

Hallo Franz,

... dass in meiner Formel die beiden auszuwertenden Matrixbereiche durch eine Semikolon getrennt werden. Dadurch muss die Bedingungsprüfung (JAHR(A2:A100)=2019) die nur eine Matrix aus WAHR und FALSCH ergibt und diese so durch SUMMENPRODUKT() nicht ausgewertet werden kann mit 1 multipliziert werden, damit die Matrix aus WAHR und FALSCH-Werten in eine aus 0 und 1 Zahlenwerten gewandelt wird.

Durch das Semikolon ist gewährleistet, dass in D2:D100 auch Textwerte oder ="" stehen können, die dann ohne Fehlermeldung einfach ignoriert werden in der Auswertung.

Gruß Werner
.. , - ...

Betrifft: AW: de entscheidende Unterschied ist ...
von: Franz W.
Geschrieben am: 22.10.2020 14:25:02

Vielen Dank, Werner!

Und viele Grüße
Franz

Betrifft: AW: gerne owT
von: neopa C
Geschrieben am: 27.10.2020 09:32:30

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "Werte addieren wenn..."