Microsoft Excel

Herbers Excel/VBA-Archiv

Excel Kalender

Betrifft: Excel Kalender von: Osi
Geschrieben am: 03.11.2020 13:40:29

Hallo Zusammen
Habe da ein Problem, ich hoffe es kann mir Jemand helfen ! Ich habe da auch eine Excel Datei angehängt.

Also wenn ich in der Zelle C5 denn Text " HP L " habe, dann möchte ich das nach unter ziehen, aber C6 ist ein Sonntag (Blau) da darf nichts stehen. In der Zelle C7, das ein Montag sollte dann der Text " HP R " sein, in der Zelle C8 der Text " 1 L " und das immer so weiter bis Ende Jahr. Ausgenommen die mit mit Blau Markierten Zellen dürfen nicht beschrieben werden. (Sonn und Feiertage)
Der Text " HP L , HP R, usw. ist in der Spalte AZ17 bis AZ26 hinterlegt (das ist auch die Reinfolge)
In der Zelle A1 kann man das Jahr aussuchen, dann sollte alles vom Jahr zuvor
übernommen werden. (auch die Einträge " HP L, HP R, 1L usw."
Ich hoffe Ihr könnt mir helfen!

https://www.herber.de/bbs/user/141274.xlsx

grüsse und bleibt gesund !

Betrifft: AW: Excel Kalender
von: SF
Geschrieben am: 03.11.2020 13:48:47

Hola,

wenn du schon das Forum wechselt, verlinke wenigstens deine Beiträge untereinander.
Danke.

Gruß,
steve1da

Betrifft: AW: Excel Kalender
von: Osi
Geschrieben am: 03.11.2020 14:20:15

Hallo steve1da

Danke für den Deinen Tip (das wusste ich nicht Sorry)

Aber jetzt die Frage an Dich, kannst das Problem beim Kalender Lössen oder nicht.

Gruss

Betrifft: AW: nachgefragt ...
von: neopa C
Geschrieben am: 03.11.2020 15:12:57

Hallo Osi,

... wieso beziehst Du Dich in der Formel C5 auf A4? Damit würde z.B. gegen Deine Vorgaben im Jahr 2022 am Sonntag den 2.1. HP L stehen.

Gruß Werner
.. , - ...

Betrifft: AW: nachgefragt ...
von: Osi
Geschrieben am: 03.11.2020 16:08:39

Hallo Werner

Ich danke Dir, das Du denn Fehler bemerkt hast.
Es muss sich ja auf B5 beziehen also =WENN(WOCHENTAG(B5;2)=7;"";AZ17) dann geht es. Super danke!

Noch etwas was mich interessiert, wie funktioniert es am Montag das währe dann B7, denn wenn
ich die Formel runterziehe macht er am Sonntag zwar keinen Eintrag, aber AZ18 ist dann vergeben
und wir am Montag AZ19 eingetragen.(gibt es da eine Lösung)

https://www.herber.de/bbs/user/141281.xlsx (Neu)

Gruss

Betrifft: AW: eine Lösung dafür ...
von: neopa C
Geschrieben am: 03.11.2020 16:42:49

Hallo Osi,

... könnte z.B. wie folgt aussehen: Schreibe in C5 den von Dir vorgesehenen Wert ohne Formel. Dann in C6 folgende Formel:

=WENN(WOCHENTAG(B6;2)=7;"";WENN(VERWEIS(9;1/(C$4:C5<>"");C$4:C5)="4 R";"HP L";INDEX(AZ:AZ; VERGLEICH(VERWEIS(9;1/(C$4:C5<>"");C$4:C5);AZ:AZ;0)+1)))


und kopiere diese ziehend nach unten.

Gruß Werner
.. , - ...

Betrifft: AW: ergänzender Hinweis ...
von: neopa C
Geschrieben am: 03.11.2020 17:00:31

Hallo Osi,

... da Du ja Feiertage unberücksichtigt haben möchtest, und Du diese in der Spalte auch beschriftest, sollten diese beide Formeln zwingend zu einer zusammengeführt werden und außerdem für den jeweiligen Monatsanfang angepasst werden. Dazu würde ich Dir raten zunächst Deine Feiertagsliste zu einer Formatierten Liste zu definieren und die einzelnen ergänzenden Formelteile zunächst für sich zu definieren und dann zu einer benannten Formel zusammenzuführen und diese anstelle der dann doch ziemlich komplexen Formel einzusetzen.

Gruß Werner
.. , - ...

Betrifft: AW: ergänzender Hinweis ...
von: Osi
Geschrieben am: 03.11.2020 17:23:46

Hallo Werner

Ich danke Dir vielmals,
für die Super Lange Formel (Da kämme ich wahrscheinlich nie darauf)

Viele Grüsse
Osi

Betrifft: AW: bitteschön owT
von: neopa C
Geschrieben am: 03.11.2020 19:06:23

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "Excel Kalender"