Microsoft Excel

Herbers Excel/VBA-Archiv

Zelle Wert übergeben

Betrifft: Zelle Wert übergeben
von: Robert
Geschrieben am: 16.04.2003 - 09:16:22

Hallo,

ich versuche seit langem einen Wert in eine Zelle zu übergeben. Dieser Wert soll erst dann in eine Zelle geschrieben werden, wenn die Wenn-Funktion zutrifft. Ebenso soll der Wert in der selben Zelle stehen, von dem aus die Funktion aufgerufen wird.

in etwa so:
notiert in Zelle A1:
=WENN(A2>A3;B2 und B3=B2;A2)
Es soll also der Wert aus B2 übernommen werden und auch der Wert aus B2 in B3 reingeschrieben werden.

Kann mir jemand hierzu Hilfe geben?

Vielen Dank

Robert

  

Re: Zelle Wert übergeben
von: Yal
Geschrieben am: 16.04.2003 - 10:20:49

Formeln in Zelle arbeiten nur für sich selbst, d.h. um eine Werte im A1 zu bekommen, brauchst Du eine Formel in A1, um eine Werte in B3 zu bekommen brauchst Du eine Formel in B3
Also in A1 = Wenn(A2>A3;B2;A2)
und in B3 = Wenn(A2>A3;B2;A2)

Yal

  

Alternative
von: Robert
Geschrieben am: 16.04.2003 - 10:24:41

Kann ich einen Wert stehen lassen, wenn bei einer WENN-Funktion ein FALSCH herauskommt?
irgendwie so:
=WENN(A2

  

Re: Alternative
von: Yal
Geschrieben am: 16.04.2003 - 13:28:43

ich verstehe die Frage nicht.

= wenn (Bedingung; Ergebnis bei Bedingung als Richtig bewertet; Ergebnis bei Bed. als falsche bewertet)

es gibt keine Möglichkeit, eine Wenn-Formel in eine Zelle A2 zu schreiben, und gleichzeitig die vorhandene Werte weiterzubehalten.
Dies kann nur durch Makro erreicht:


if Range("A2").Value > Range("A3").Value then
    Range("A2") = Range("B2").Value
else
   'nothing: A2 steht!
End if