Microsoft Excel

Herbers Excel/VBA-Archiv

sverweis

    Betrifft: sverweis von: Jochen
    Geschrieben am: 01.09.2003 17:02:49

    hallo zusammen,
    kann man bei einem sverweis eine Funktion "kleiner als" definieren. wenn nicht, wie durchsuche ich eine Tabelle mit einem Suchkriterium "kleiner als".

    Bsp. Maßangabe ist z.b von 650-850 entspricht 1, 850-900 entspricht 2. Der ermiitelte Wert ist 700. Entspricht also 1.
    Ich hoffe damit ist in etwa erklärt was ich möchte.
    Vielen dank für Eure Hilfe

      


    Betrifft: AW: sverweis von: Marcus Rose
    Geschrieben am: 01.09.2003 17:09:17

    Hallo,

    meinst Du das so?

    Tabelle1
     ABC
    11700 2
    12   
    13   
    14   
    1506501
    166508502
    178509503
    18   
    Formeln der Tabelle
    C11 : =SVERWEIS(A11;A15:C17;3,1)
    Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
    Gruß Marcus

    Die neue Excel-Homepage für Anfänger

      


    Betrifft: AW: sverweis von: Jochen
    Geschrieben am: 02.09.2003 08:25:21

    0-8m Profilgr.
    1530 1
    1745 2
    1820 3
    1930 4
    2600 5
    hallo ,
    leider ist mir mit der Antwort nicht geholfen trotzdem vielen Dank. Oben nochmnal einen Tabelle die ich mit Sverweis duchsuchen möchte. Das Suchkriterium ist 1630 was Profilgruppe 2 entsprechen würde. Sollte das Suchkriterium 1760 betragen müsste der Wert 3 sein. Das zweite Problem ist. das die Werte in der Spalte 0-8m nicht immer gleich sind. ich als die Tabelle jeweils nach dem nächst größeren Wert durchsuchen möchte. Ich hoffe diese erkllärung verdeutlicht meine Problematik etwas besser als die erste. Vielen Dank für die Hilfe.


      


    Betrifft: AW: sverweis von: Panicman
    Geschrieben am: 02.09.2003 08:58:33

    Hallo Jochen,

    versuchs mal für dein Beispiel mit

    =INDEX($B$1:$B$5;VERGLEICH(C1;$A$1:$A$5;1)+1;1)

    in C1 steht das Suchkriterium

    Gruß
    Holger


      


    Betrifft: AW: sverweis von: Panicman
    Geschrieben am: 01.09.2003 17:13:18

    Hallo Jochen,

    vielleicht meinst du das:

    A B C D
    650 1 700 =SVERWEIS(C1;$A$1:$B$3;2;1)
    850 2
    901 3

    Gruß
    Holger


     

    Beiträge aus den Excel-Beispielen zum Thema " sverweis"