Microsoft Excel

Herbers Excel/VBA-Archiv

Simple Frage zu Formaten

    Betrifft: Simple Frage zu Formaten von: Steffen
    Geschrieben am: 01.09.2003 23:02:02

    Hallo alle zusammen,

    habe eine recht bescheidene Frage:

    Wie schaffe ich es benutzerdefinierte Zahlenformate(Prozente, Währungen,...) also #.##0,00 oder #.##0,00 €;[Rot]-#.##0,00 oder ähnliches direkt in ein Tabellen-Kästchen zu schreiben???

    Ich will erreichen, dass das Kästchen bei Vorliegen eines Wertes in einem anderen Kästchen(und nur dann), ein best. Format(#,##) annimmt.

    Danke für eure Hilfe
    Steffen

      


    Betrifft: AW: Simple Frage zu Formaten von: RainerW
    Geschrieben am: 01.09.2003 23:34:35

    Hallo Steffen,
    das erreichst mit dem Befehl unter
    Menü Format "bedingte Formatierung..."


    Gruß
    Rainer


      


    Betrifft: AW: Simple Frage zu Formaten von: RainerW
    Geschrieben am: 02.09.2003 00:00:50

    Hallo Steffen,

    ich habe mit meiner vorherigen Antwort eine Formatierung der Zellen und
    Schrift beschrieben. Du wolltest aber etwas anderes.

    Ich habe es so verstanden:
    du möchtest z.B., wenn in A1 ein bestimmter Wert steht, das B1 eine
    bestimmte Formatierung bekommt. Dazu möchtest du aber die Formatierung in die
    Zelle B1 schreiben.
    In B1 muss aber irgend etwas stehen, das formatiert werden kann.
    Zwei "Köpfe kriegt man aber nur unter einen Hut", wenn man TEXT daraus macht.

    Schreibe in Zelle B1 die Formel:
    =WENN(A1>100;TEXT(A1*5;"#.##0,00") & " Euro";"")

    und in A1 einen Wert größer 1000 (wegen Tausenderpunkt).

    Und nun nach deinen Formatvorstellungen anpassen.

    Gruß
    Rainer


      


    Betrifft: AW: Simple Frage zu Formaten von: Björn
    Geschrieben am: 02.09.2003 00:23:08

    Huhu Steffan,

    per VBA läßt sich das auch lösen, indem Du für das entsprechende Tabellenballt diesen Code eingibst:


    Private Sub Worksheet_Change(ByVal Target As Excel.Range)
    If Cells(1, 1) = 1 Then
    Cells(1, 2).NumberFormat = "#,##0.00"
    End If
    End Sub
    


    Viele Grüße

    Björn


     

    Beiträge aus den Excel-Beispielen zum Thema " Simple Frage zu Formaten"