Microsoft Excel

Herbers Excel/VBA-Archiv

Mittelwertberechnung

    Betrifft: Mittelwertberechnung von: Tobias W
    Geschrieben am: 02.09.2003 18:55:15

    Hallo,
    in meiner Tabelle stehen in der Spalte A verschiedenste Kennzahlen wie Umsatz, Wareneinsatz usw. In den folgenden 12 Spalten werden die jeweiligen Monatswerte dieser Kennzahlen eingetragen.

    Hinter den 12 Spalten ist eine weitere Spalte, in der der Mittelwert ausgewiesen werden soll. Und zwar der Mittelwert nur aus den bereits ausgefüllten Spalten.

    Jetzt das Problem: Die Daten in den Monatsspalten werden zum Teil aus zig anderen Tabellen übergeben. Da ich den gesuchten Mittelwert nur bekomme, wenn die noch nicht erreichten Monate leer sind (und nicht Null, sonst bezieht sich der Mittelwert immer auf alle zwölf Felder), muss ich sämtlich Daten aus den anderen Tabellen "leer" übergeben, wenn sie noch nicht gepflegt sind. Das ist aber aufgrund des Pflegeaufwands (zig Hintergrundtabellen) nicht machbar. Weiß jemand was Besseres?

    Jetzt schon vielen Dank,
    Gruß Tobias

      


    Betrifft: {=MITTELWERT(WENN(A1:L1<>0;A1:L1))} von: Boris
    Geschrieben am: 02.09.2003 18:59:01

    Hi Tobias,

    ...als Array-Formel; {geschweifte Klammern} nicht eingeben, sondern Formeleingabe mit Strg-Shift-Enter abschließen.
    Nullwerte (auch leere Zellen) werden dadurch ignoriert.

    Grüße Boris


      


    Betrifft: Mittelwert ohne Leerzellen (auch ohne Nullen?) von: Franz Pölt
    Geschrieben am: 02.09.2003 23:51:17

    Hallo Tobias und Boris,

    schaut euch mal das an, interessant, nicht wahr?

    Excel Jeanie HTML
    Formeln der Tabelle
    A2 : {=MITTELWERT(WENN(A1:L1;A1:L1))}
    B2 : =MITTELWERT(WENN(A1:L1<>0;A1:L1))
    C2 : {=MITTELWERT(WENN(A1:L1<>0;A1:L1))}
    Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download   Servus aus dem Salzkammergut Franz

      


    Betrifft: Interessant - trag die Formel aus B2... von: Boris
    Geschrieben am: 03.09.2003 00:17:18

    Hi Franz,

    ...mal in A3 ein - Ergebnis: 0 !?!

    Unter dem Strich liefert die Formel in B2 das gleiche Ergebnis wie =MITTELWERT(A1:L1).
    Allerdings scheint es mit der WENN-Funktion tatsächlich eine Abhängigkeit zur Spalte zu geben - wenn in A1 nix steht und die Formel in A3 eingetragen wird, ist das Ergebnis 0. Daher: Wenn die Formel in B2 eingetragen wird, ist das Ergebis 1,75 - weill eben in B2 ein Wert ungleich Null steht. Löscht man den Wert in B1 (oder ändert man ihn auf 0), dann ist auch das Ergebnis der Formel in B2 = 0. Trägt man aber einen Wert ungleich Null in A1 ein, dann ist auch das Ergebnis der Formel in A3 ungleich Null...

    Es scheint also tatsächlich Abhängigkeiten - vom Formeleintrag aus gesehen - zu geben...INTERESSANT!
    Das sollte man doch mal weiter verfolgen...

    Grüße Boris


      


    Betrifft: Nicht Interessant - weil Fehler von: galenzo
    Geschrieben am: 03.09.2003 08:17:23

    Schließe die Formel in B2 mit UMSCH+STRG+ENTER ab, damit es auch eine Array-Formel wird...


      


    Betrifft: Das ist mir schon klar... von: Boris
    Geschrieben am: 03.09.2003 09:13:38

    Hi Galenzo,

    ...diese Variante hat Franz ja AUCH gepostet - aber er ist halt ein Tüftler und Ausprobierer - und da stößt er halt manchmal auf merkwürdige Dinge. Und ich finde es SEHR merkwürdig, dass die selbe Formel - OHNE die { } eingegeben - unterschiedliche Ergebnisse liefert, wenn in der Zeile 1 der gleichen Spalte entweder eine Null oder eine Zahl ungleich Null eingetragen wird.

    Grüße Boris


      


    Betrifft: AW: Das ist mir schon klar... hmm.. von: Galenzo
    Geschrieben am: 03.09.2003 11:18:25

    nein, ich meinte: Franz hat in seiner geposteten Beispieltabelle die { } in der Formel in B2 vergessen - oder bewußt weggelassen?
    Das Übereinstimmen er Ergebnisse ist meiner Meinung nach nur zufällig. Die Arbeitsweise von Arrayformeln ist an sich eine andere und läßt sich SO nicht vergleichen.

    mfg - Galenzo


      


    Betrifft: Definitiv: BEWUSST von: Boris
    Geschrieben am: 03.09.2003 15:09:50

    Hi Galenzo,

    ...Franz geht virtuos mit Array-Formeln um - und ich glaube auch einige Ahnung davon zu haben. Insofern geht das schon wieder einen Gedankengang weiter, der zunächst einem "Anfängerfehler" anmutet, in der Tat aber bewusst produziert wurde um Seltsamkeiten in der "Denkweise" von Excel aufzudecken...;-)

    Grüße Boris


      


    Betrifft: Aha! hab ich falsch verstanden :-) o.T. von: Galenzo
    Geschrieben am: 04.09.2003 08:22:07