Das Archiv des Excel-Forums

Curser - Zellbezeichnung

Bild

Betrifft: Curser - Zellbezeichnung
von: Martin

Geschrieben am: 27.09.2003 14:44:41

Ich möchte bei der Formel = sverweis(b6;$A$8:$F$14;2)
an Stelle von b6 die aktuelle Curserposition einsetzen.
Geht das? (Die Anzeige sollte nur erscheinen wenn b6 auch tatsächlich eine Zahl ist)

Danke
Bild


Betrifft: Habe mich falsch ausgedrückt
von: Martin
Geschrieben am: 27.09.2003 15:01:00

an Stelle von b6 ein markiertes Feld.
(Die Anzeige sollte nur erscheinen wenn das markierte Feld auch tatsächlich eine Zahl enthält)


Bild


Betrifft: AW: Habe mich falsch ausgedrückt
von: Björn
Geschrieben am: 27.09.2003 15:19:33

Hallo Martin,

Vorschlag:

in die VBA-Entwicklerumgebung wechseln mit ALT+F11, Tabellenblatt Tabelle1 per Doppelklick auswählen und folgenden Code eingeben:


Private Sub Worksheet_SelectionChange(ByVal Target As Excel.Range)
ThisWorkbook.Sheets("tabelle1").Range("B5") = Selection.Value
End Sub


wenn Du danach wieder zur Tabelle1 wechselst, dort in die Zellen A5 und A6 werte eingibst und danach markierst, sollte der Wert der jeweils angeklickten Zelle in G5 stehen. Um das Zahlenproblem kannst Du Dich auf Excel-Ebene kümmern:

=WENN(ISTFEHLER(SVERWEIS(G5;$A$8:$F$14;2));"FEHLER";SVERWEIS(G5;$A$8:$F$14;2))

Gruß

Björn


Bild


Betrifft: Danke funktioniert
von: Martin
Geschrieben am: 28.09.2003 20:10:25

Hat ein wenig gedauert - ab jetzt läufts.
Danke


 Bild