Herbers Excel-Forum - das Archiv

Wert suchen

Bild

Betrifft: Wert suchen
von: Elena
Geschrieben am: 02.10.2003 15:42:34
Hallo,
ich habe ein Problem:
Zuerst muss ich den ersten negativen Wert in einer Spalte suchen, dann in einer anderen Spalte den entsprechenden Wert finden.
Das heißt: wenn die erste negative Zahl in A10 steht, muss das Programm mir den Wert aus B10 geben.
Vielen Dank im Vorraus
Elena

Bild

Betrifft: AW: Wert suchen
von: Patrick
Geschrieben am: 02.10.2003 15:51:42
Hallo Elena,

du kannst in der z.B. in der Spalte C die Formel "=WENN(a2<0;b2;0)" einfügen, dann wird dir bei ein wert kleiner als 0 ist in der Spalte A, der waert aus spalte B angezeigt, ansonsten 0
Bild

Betrifft: AW: Wert suchen
von: xXx
Geschrieben am: 02.10.2003 16:08:03
Hallo,
diese Formel liefert dir den entsprechenden Wert:

{=INDEX(B1:B1000;VERGLEICH(WAHR;A1:A1000<0;0))}

Matrixformel! Geschweifte KLammern nicht eingeben, sondern Formel mit shift+strg+enter abschließen.

Gruß aus'm Pott
Udo
http://www.excelerator.de

P.S. Das Forum lebt auch von den Rückmeldungen der Frager an die Antworter!
Bild

Betrifft: AW: Wert suchen
von: Elena
Geschrieben am: 06.10.2003 08:37:54
Hallo,
es hat leider nicht geklappt. Bei der Formel von xXx kommt #NV raus. Vielleicht habe ich die Aufgabe falsch erklärt.In Spalte A werden Werte in absteigender Reihenfolge angeordnet, in Spalte B stehen die dazugehörige Werte. In Zelle C1 muss ich die Formel eingeben, die mir den Wert aus Spalte B (z.B B10) gibt, weil in Spalte A (in A10 steht -100) die erste negative Zahl steht(die Zelle mit negativen Wert kenne ich nicht,muss die Formel suchen). Mich interessiert nur die Zahl aus der Spalte B, andere Werte sind unwichtig.
Danke
Elena
 Bild
Excel-Beispiele zum Thema " Wert suchen"
Zellinhalt suchen und Zelle auswählen Suchbegriff über mehrere Tabellenblätter suchen.
Suchen und weitersuchen Zahl +/- 1 suchen
Ein Zeichen in einer Formel suchen Datum suchen und Wert eintragen
Wert in Tabelle suchen und in UserForm ausgeben Letzte Zelle mit Inhalt suchen
Textdatei nach Begriff durchsuchen und Fundzeile importieren Wert in Array suchen, ohne jedes Datenfeld abzufragen