Das Archiv des Excel-Forums

Zahlen vergleichen

Bild

Betrifft: Zahlen vergleichen
von: Versemann

Geschrieben am: 03.10.2003 11:07:33

Ich möchte Zahlen vergleichen und auswerten.

In Zelle A5:A15 stehen Zahlen die nicht geändert werden
In Zelle C5:C15 gebe ich täglich neue Zahlen ein
Nun soll Excel die Zahlen vergleichen und mir als Ergebnis zeigen wie viele
Zahlen(Zellen A5:A15) mit den Zahlen(Zellen C5:C15) übereinstimmen.
Ich möchte dann das Ergebnis in Zelle E5 haben
Schön wäre es wenn mir Excel die Übereinstimmenden Zahlen von Zelle A5:A15 noch mit Füllfarbe hervorhebt
Kann mir jemand helfen…mir ein Beispiel per Mail senden??

vielen Dank
Bild


Betrifft: AW: Zahlen vergleichen
von: andreas e
Geschrieben am: 03.10.2003 11:31:56

hallo, wie wäre es mit diesem Lösungsansatz ,
einfach noch etwas auf dich anpassen:
 
 ABCD
1feste ZahlenveränderlichHilfsspalteSumme
21213
32120 
4321 
5411 
6560 
Formeln der Tabelle
C2 : =ZÄHLENWENN($A$2:$A$6;B2)
D2 : =SUMME(C2:C6)
C3 : =ZÄHLENWENN($A$2:$A$6;B3)
C4 : =ZÄHLENWENN($A$2:$A$6;B4)
C5 : =ZÄHLENWENN($A$2:$A$6;B5)
C6 : =ZÄHLENWENN($A$2:$A$6;B6)
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
B21. / Formel ist =ZÄHLENWENN($A$2:$A$6;B2)Abc
B31. / Formel ist =ZÄHLENWENN($A$2:$A$6;B3)Abc
B41. / Formel ist =ZÄHLENWENN($A$2:$A$6;B4)Abc
B51. / Formel ist =ZÄHLENWENN($A$2:$A$6;B5)Abc
B61. / Formel ist =ZÄHLENWENN($A$2:$A$6;B6)Abc
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
Gruß Andreas E http://www.skripteundaufgaben.de viele kostenlose Downloads und Links zu EXCEL und mehr http://www.fachforen.de eine Linksammlung zu diversen fachforen

Bild


Betrifft: AW: Zahlen vergleichen
von: Versemann
Geschrieben am: 03.10.2003 12:15:01

Hallo andreas,
das sieht ja schon sehr gut aus...vielen dank!
..aber geht das auch ohne Hilfsspalte??
..und die füllfarbe bei den festen Zahlen??
Versemann


Bild


Betrifft: AW: Zahlen vergleichen
von: andreas e
Geschrieben am: 03.10.2003 13:35:01

hallo, hier nochmals ein ansatz auf basis deiner Tabelle (ohne VBA!)
ganz ohne Hilfszelen habe ich das so nicht geschafft ! Da fällt mir spontan nur ne VBA Lösung vonHajo an "Farben zählen)

 
 ABCDE
1     
2     
3     
4 So sollte das Ergebniss aussehen Andreas   
5     
6     
7     
8 Feste ZahlenVeränderliche ZahlenErgebnis 
9   2 
10 13561evtl. Schriftfarbe auf weiss setzen !??
11 5180evtl. Schriftfarbe auf weiss setzen !??
12 78131evtl. Schriftfarbe auf weiss setzen !??
13 8980evtl. Schriftfarbe auf weiss setzen !??
14 10110evtl. Schriftfarbe auf weiss setzen !??
15 45780evtl. Schriftfarbe auf weiss setzen !??
16     
17 Ich möchte die veränderlichen Zahlen eingeben…das Ergebnis in D10 ablesen und zusätzlich das Ergebniss mit Füllfarbe bei den festen Zahlen sehen..   
18     
19 Wäre super wenn du mir helfen könntest..   
20 Vielen Dank schon mal dafür!!!   
Formeln der Tabelle
D9 : =SUMME(D10:D15)
D10 : =ZÄHLENWENN($C$10:$C$15;B10)
D11 : =ZÄHLENWENN($C$10:$C$15;B11)
D12 : =ZÄHLENWENN($C$10:$C$15;B12)
D13 : =ZÄHLENWENN($C$10:$C$15;B13)
D14 : =ZÄHLENWENN($C$10:$C$15;B14)
D15 : =ZÄHLENWENN($C$10:$C$15;B15)
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
B101. / Formel ist =ZÄHLENWENN($C$10:$C$15;B10)Abc
B111. / Formel ist =ZÄHLENWENN($C$10:$C$15;B11)Abc
B121. / Formel ist =ZÄHLENWENN($C$10:$C$15;B12)Abc
B131. / Formel ist =ZÄHLENWENN($C$10:$C$15;B13)Abc
B141. / Formel ist =ZÄHLENWENN($C$10:$C$15;B14)Abc
B151. / Formel ist =ZÄHLENWENN($C$10:$C$15;B15)Abc
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
Gruß Andreas E http://www.skripteundaufgaben.de viele kostenlose Downloads und Links zu EXCEL und mehr http://www.fachforen.de eine Linksammlung zu diversen fachforen

Bild


Betrifft: Und ohne Hilfsspalte geht´s so:
von: Boris
Geschrieben am: 03.10.2003 14:06:05

Hi Andreas,

 ABC
1Übereinstimmung5 
2   
3   
4   
51 6
63 2
77 22
811 18
913 3
105 4
114 5
1216 99
1355 202
1422 1
1520 0
Formeln der Tabelle
B1 : =SUMMENPRODUKT(N(ISTZAHL(VERGLEICH(C5:C15;A5:A15;0))))
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A51. / Formel ist =ZÄHLENWENN($C$5:$C$15;A5)Abc
A61. / Formel ist =ZÄHLENWENN($C$5:$C$15;A6)Abc
A71. / Formel ist =ZÄHLENWENN($C$5:$C$15;A7)Abc
A81. / Formel ist =ZÄHLENWENN($C$5:$C$15;A8)Abc
A91. / Formel ist =ZÄHLENWENN($C$5:$C$15;A9)Abc
A101. / Formel ist =ZÄHLENWENN($C$5:$C$15;A10)Abc
A111. / Formel ist =ZÄHLENWENN($C$5:$C$15;A11)Abc
A121. / Formel ist =ZÄHLENWENN($C$5:$C$15;A12)Abc
A131. / Formel ist =ZÄHLENWENN($C$5:$C$15;A13)Abc
A141. / Formel ist =ZÄHLENWENN($C$5:$C$15;A14)Abc
A151. / Formel ist =ZÄHLENWENN($C$5:$C$15;A15)Abc
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download   Grüße Boris

Bild


Betrifft: @boris - das lerne ich wohl NIE !
von: andreas e
Geschrieben am: 03.10.2003 14:17:29

Kompliment an den oder die Formel "Gurus " hier !
schönes langes we
andreas e


Bild


Betrifft: AW: Und ohne Hilfsspalte geht´s so:
von: Versemann
Geschrieben am: 03.10.2003 14:39:44

Hi Boris,
kannst du mir mal die Tabelle fertig schicken??..wäre toll!
Danke Harry

PS: Wie funktioniert das mit den Farben...denn meine Tabelle geht bis A99


Bild


Betrifft: Da brauch ich nix zu schicken...
von: Boris
Geschrieben am: 03.10.2003 16:03:48

Hi Harry,

das ist schnell erklärt:
Selektiere A5 - Format -> Bedingte Formatierung -> Formel ist:
=ZÄHLENWENN($C$5:$C$15;A5)
und Format roter Hintergrund.

Mit dem Pinsel(=Format übertragen) kannst du es jetzt einfach auf die anderen Zellen in Spalte A (bis A99) übertragen - fertig.

Grüße Boris


Bild


Betrifft: AW: Zahlen vergleichen
von: Beni
Geschrieben am: 03.10.2003 11:36:41

Hallo Wesemann,
markiere A5:A15, Format/Bedinge Formatierung/Formel ist =ZÄHLENWENN($C$5:$C$15;$A5)
Gruss Beni


Bild


Betrifft: AW: Zahlen vergleichen
von: Versemann
Geschrieben am: 03.10.2003 12:17:40

Danke Beni!
aber ich habe schon fast die richtige lösung...siehe antwort andreas..


 Bild

Excel-Beispiele zum Thema " Zahlen vergleichen"

Vorkommen von Zahlenreihen in Spalten download Zeichenfolgen in Zahlen nach Textimport download
Zahlenformatierung mit Punkt nach der 1. Ziffer download Namen von TextBoxes hochzählen download
Zählen formatierter Zellen download Autofilter auch mit Ziffern von Zahlen download
Addition der absoluten Zahlen download Eingabe von positiven Zahlen erzwingen download
Zufallszahlen generieren, die sich nicht wiederholen download Summenformel unter Zahlenreihe eintragen download
Nur AJM in TextBox akzeptieren und Anzahl zählen download Teilergebnisse in Zahlenreihe eintragen und löschen download
Nach Textimport Strings in Zahlen wandeln download Alle Formeln und Zahlen löschen download
Werte nur mit Zahlenformaten übertragen download Worte in einem vorgegebenen Bereich zählen download
Anzahl in einer Liste vorkommender Namen zählen download Zellwerte über SpinButton und ScrollBar hochzählen download
Zahlenstring mit Formel auslesen und Fehlermeldung verhindern download Label in Zelle A1 bei jedem Ausdruck um 1 hochzählen download
Anzahl Artikelnummern auf Deckblatt nach Blättern zählen download Als Text vorhandene Werte in Zahlen umwandeln download
Den jeweils letzten Wert einer Zahlenreihe als Multiplikator download Mittelwert einer Zahlenreihe bis zur Zeile mit der Formel download
Lottozahlen-Generator download Lücken aus Zahlenreihe listen download
Zahlen in Abhängigkeit von ihrem Wert multiplizieren download Gleiche Zufallszahlen zählen und in Diagramm anzeigen download
Zufallszahlen bis zum 4-fachen Wert generieren download Reihenfolge einer Zahlenreihe nach dem Zufallsprinzip variieren download
Anzeige eines Zahlwortes synchron zur Textbox-Zahleneingabe download Zahlen unter Berücksichtigung von Monat und Jahr summieren download
Tabelle gem. hinterlegten Zahlenformaten formatieren download Zählen von in einer Formel vorkommenden Zahlen download
Addition der 10 höchsten Werte einer Zahlenreihe download Spaltenbreite gemäß den in den Zellen stehenden Zahlen festlegen download
Zeilen zählen, in denen zwei Bedingungen zutreffen download Leerzeichen zwischen Zeichen- und Zahlenfolge entfernen download
Alle Zellen mit einer vorgegebenen Hintergrundfarbe zählen download Zahlen eines Bereiches jeweils 4 mal in eine Spalte schreiben. download
Kennzeichnung von Lottogewinnzahlen download Strings, die wie Zahlen aussehen, in Zahlen umwandeln download
Zahlen-Formatierungs-Dialog aus UserForm aufrufen download Zahlenmarkierungen in einer Lottoliste download
Datensätze zählen, die in einigen Spalten identisch sind download Zeit in vorgegebenem Intervall hochzählen download
Alle ungeraden Zahlen markieren download Zeichen als Zahlen darstellen download
Teilungszahlen und Sitzfolge nach dem Höchstzahlverfahren download Eingeblendete Zeilen mit Werten zählen download
Zellen vergleichen und markieren download Tabellen vergleichen download
Spalten A und B vergleichen und Doppel in C listen download Werte vergleichen download
Bereiche auf Übereinstimmung vergleichen download Daten in jeweils einer Spalte zweier Tabellen vergleichen download
Werte vergleichen und Ergebnis in Tabelle eintragen download Tabellen vergleichen und Zeilen ersetzen download
Tabellen vergleichen und bei Nichtübereinstimmung markieren download Textdateien vergleichen und Unterschiede dokumentieren download
Spalte A mit B vergleichen und Doppel in C eintragen download Telefonnumern mit Liste vergleichen und durch Namen ersetzen download
Werte vergleichen und übertragen download Teilstrings vergleichen und markieren download
Textmuster vergleichen download