Formal nach VBA?

Bild

Betrifft: Formal nach VBA?
von: Franklin
Geschrieben am: 14.10.2003 15:24:43

Hi,

habe folgende Formel in der Zelle C5:

{=SUMME(WENN([Stats.xls]Tabelle1!$G$6:$G$6000="2003";1;0)*WENN([Stats.xls]Tabelle1!$F$6:$F$6000="10";1;0)*WENN([Stats.xls]Tabelle1!$V$6:$V$6000="HP";1;0))}

Die Tabelle sieht so aus:

Tabelle1 (2)
 ABCDEFGHI
2         
3  HP
4  AllesEndbearbeitungBWRPHEMAHD
5Oktober 2003 #BEZUG!      
6November 2003        
7Dezember 2003        
8         
9Januar 2004        
10Februar 2004        
11März 2004        
12April 2004        
13Mai 2004        
14Juni 2004        
15Juli 2004        
16August 2004        
17September 2004        
18Oktober 2004        
19November 2004        
20Dezember 2004        
Formeln der Tabelle
C5 : {=SUMME(WENN([Stats.xls]Tabelle1!$G$6:$G$6000="2003";1;0)*WENN([Stats.xls]Tabelle1!$F$6:$F$6000="10";1;0)*WENN([Stats.xls]Tabelle1!$V$6:$V$6000="HP";1;0))}
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Funkt ja auch.
Würde das gerne nur etwas dynamischer gestalten. Und zwar würde ich gerne aus dem Dropdownfeld (Daten-Gültigkeit) die Bedingung zum Zählen auswählen.

Sodass die Formeln z.B. so lauten würde:
{=SUMME(WENN([Stats.xls]Tabelle1!$G$6:$G$6000="2003";1;0)*WENN([Stats.xls]Tabelle1!$F$6:$F$6000="10";1;0)*WENN([Stats.xls]Tabelle1!$V$6:$V$6000=C3;1;0))}

C3 - ist dann also die hiesige und nicht die Quelltabelle! Aber so funkt das nicht! Wie müßte ich das Umstellen, damit die eine Bedingung zum zählen aus dem Wert des Dropdown genommen wird?
Danke Euch
Franklin
Bild


Betrifft: AW: Formal nach VBA?
von: Ramses
Geschrieben am: 14.10.2003 15:58:28

Hallo

verwende statt SUMME die Funktion SUMMENPRODUKT ohne WENN.

=SUMMENPRODUKT((Tabelle1!$G$6:$G$6000="2003")*(Tabelle1!$F$6:$F$6000="10")*(Tabelle1!$V$6:$V$6000=C3))

Dann sollte es eigentich gehen

Gruss Rainer


Bild


Betrifft: AW: Formal nach VBA?
von: Franklin
Geschrieben am: 14.10.2003 19:54:50

Hi Rainer,

danke für den Tip... werde es gleich morgen früh testen :-)

thxalot

Franklin


 Bild

Beiträge aus den Excel-Beispielen zum Thema " aus 2 Textfeldern 1 Textfeld"