SVERWEIS(..)!?

    Bild

    Betrifft: SVERWEIS(..)!?
    von: kostro
    Geschrieben am: 27.10.2003 18:16:14

    Hallo!

    Ich habe mal eine Verständnis-Frage zur Formel SVERWEIS(Suchkriterium;Matrix;Spaltenindex;Bereich_Verweis)!

    Spalte A enthält KW-Werte. Spalte B enthält beliebige Werte.
    Meine Formel lautet: =SVERWEIS(G11;A1:B53;2). In G11 steht die aktuelle KW drin, also d. Wert, der gesucht werden soll. Der Bereich in dem gesucht werden soll ist A1:B53. Wenn er das Suchkriterium gefunden hat, soll er den Wert rechts daneben (aus Spalte B) auslesen.

    Nun zu meinem Problem.
    Wenn Suchkriterium 47 bis 52, dann Ergebnis: 0
    Wenn Suchkriterium 1 bis 20, dann Ergebnis: #NV
    Sobald ich als Suchkriterium einen Wert von 20 bis 46 eingebe ist alles so wie es sein soll.
    Ich verstehe dass nicht!!! Kann mich jemand aufklären???

    Spalte A | Spalte B
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    32                 333
    33
    34
    35
    36                 555
    37
    38
    39
    40
    41
    42
    43                 666
    44
    45
    46
    47
    48                 555
    49
    50
    51
    52
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20

    Bild


    Betrifft: AW: SVERWEIS(..)!?
    von: Reto
    Geschrieben am: 27.10.2003 18:26:44

    Hallo Kostro

    Dein Problem kommt daher, dass die Spalte A nicht sortiert ist. Falls das nicht möglich ist (muss auch nicht sein), lautet die Formel so:

    =SVERWEIS(G11;A1:B53;2;0)

    Der Bereich_Verweis gibt an, ob eine genaue Übereinstimmung gefunden werden soll.

    Liebe Grüsse und viel Erfolg wünscht Dir
    Reto


    Bild


    Betrifft: AW: SVERWEIS(..)!?
    von: kostro
    Geschrieben am: 27.10.2003 20:29:03

    Hallo Reto,

    Dein Tipp funktioniert super. Allerdings habe ich eben festgestellt, dass es bei der KW 20 Probleme geben wird, denn die ist zweimal vergeben(für 2003 u. 2004). Also ist es besser, wenn ich das Jahr noch mit hinzu nehme.
    Nun müsste ich fragen:

    Wenn KW und Jahr gefunden wurden, dann liefere den Wert aus Spalte C.

    KW und Jahr stehen in zwei dafür vorgesehenden Feldern (KW=N3, Jahr=O3).

    Nun habe ich mal probiert: (klappt aber nicht.)
    =SVERWEIS(N3:O3;A4:C56;3;0)

    Kann das Suchkriterium überhaupt aus zwei Feldern bestehen?

    KW    Jahr    Spalte C
    20      2003    12
    21      2003    0
    22      2003    236
    23      2003    89
    24      2003    12
    25      2003    20


    Bild


    Betrifft: AW: SVERWEIS(..)!?
    von: Reto
    Geschrieben am: 29.10.2003 12:14:09

    Hallo Kostro

    Wenn Du zwei oder mehrere Bedingungen benötigst, empfehle ich Dir die Datenbankfunktion. Das geht so:

    Vergib dem Bereich der Datenbank (in Deinem Fall A4:C56) zB den Namen "Datenbank". Dem Bereich der Suchkriterien (in Deinem Fall N2:O3) gib zB den Namen "Kriterien". Achte darauf, dass in den Bereichen "Datenbank" (kW;Jahr;Spalte C) UND "Suchkriterien" (kW;Jahr) die Überschriften miteinbezogen werden (darum in N2 "kW" und in O2 "Jahr"). Die Überschriften in der Datenbank und in den Suchkriterien müssen gleich geschrieben werden!
    Schreibe zB in P3 (dem Ort, wo das Ergebnis angezeigt werden soll) folgende Formel:

    =DBPRODUKT(Datenbank;"Spalte C";Kriterien)

    Als Ergebnis erhältst Du je nach Wert in N3 und O3 das richtige Ergebnis. In der Hilfe findest Du ergänzende Angaben zu den Datenbankfunktionen, die Du vielleicht später benötigen wirst.
    Ich hoffe, meine Lösung ist das, wonach Du suchst.

    Gruss
    Reto


     Bild

    Beiträge aus den Excel-Beispielen zum Thema " Button erstellen:Drücken -> U, sonst: leer"