SVERWEIS Matrixdateien Zusammenfassen

Bild

Betrifft: SVERWEIS Matrixdateien Zusammenfassen
von: Karin
Geschrieben am: 29.10.2003 11:41:52

Hallo!
Ich habe eine Arbeitsmappe mit 21 Sheets.
Im letzten sheet sollen Summen aus den vorherigen 20 sheets gebildet werden mit dem Jahr(2003,2004...)als Kriterium = $B$16.
Geht das überhaupt wenn der Matrixbereich aus mehrer Arbeitsblätter besteht?

Ich bekomme die Meldung #NV. Und Excel blockiert nach 11 sheets.

Gibt es eine Möglichkeit eine Formel zu bilden, bei der ich den Matrixbereiche nicht jeweils einzeln angebe, sondern durch einen "von-bis" Befehl? (also: von Bookkeeping 1 bis Bookkeeping 20, zähle alle Beträge zusammen die das Jahr 2003 über sich stehen haben). Das gleiche brauche ich natürlich für die Jahre 2004-2012.


Hier ist meine bisherige Formel. Eigentlich habe ich 20 Bookkeeping sheets und nicht nur 7.

=SVERWEIS($B$16;'Bookkeeping 1'!B14:L18+'Bookkeeping 2'!B14:L18+'Bookkeeping 3'!B14:L18+'Bookkeeping 4'!B14:L18+'Bookkeeping 5'!B14:L18+'Bookkeeping 6'!B14:L18+'Bookkeeping 7'!B14:L18;2)

Danke im Voraus für eure Hilfe.
Gruss Karin

Bild


Betrifft: AW: SVERWEIS Matrixdateien Zusammenfassen
von: Franky
Geschrieben am: 29.10.2003 12:47:18

Hi,

versuchs mal mit folgender Schreibweise:

=SVERWEIS($B16$;'Bookkeeping1:Bookkeeping20'!B14:L18;2)

Gruß,
Franky


Bild


Betrifft: AW: SVERWEIS Matrixdateien Zusammenfassen
von: Karin
Geschrieben am: 29.10.2003 14:56:37

Hi Franky,

Erst mal danke für die Antwort.
Mittlerweile habe ich auf wverweis umgestellt, das Problem bleibt aber gleich.
Wenn ich Deinen Vorschlag verwende erhalte ich folgendes:


=WVERWEIS(C$14;'Bookkeeping1:[Bookkeeping20]Bookkeeping20'!B14:L18;2)

Jetzt weiss ich leider nicht weiter, da ich nicht weiss was die eckige klammer bedeutet.

Weiss du weiter????? Habe das Gefühl Du bist kurz vor der Lösung???

Gruss Karin


Bild


Betrifft: AW: SVERWEIS Matrixdateien Zusammenfassen
von: Franky
Geschrieben am: 29.10.2003 16:02:37

Die Formel als reine Summe-Funktion: =Summe('Bookkeeping1:Bookkeeping20'!B14:L18) funktioniert zumindest. Bei den Verweis Funktionen ist diese Art Syntax wohl nicht zulässig.

Du könntest es alternativ mal mit einer PIVOT-Tabelle probieren, die ja für deine Aufgabenstellung geeignet ist.

Gruß,
Franky


 Bild

Beiträge aus den Excel-Beispielen zum Thema " SVERWEIS Matrixdateien Zusammenfassen "