SUMMENDIVISION ?!

Bild

Betrifft: SUMMENDIVISION ?!
von: Gunnar Ziwes
Geschrieben am: 31.10.2003 11:02:47

Hallo Forum,

ich brauche eine Funktion ähnlich dem SUMMENPRODUKT, würde sich SUMMENDIVISION nennen, in der die 1. Spalte durch die 2. Spalte dividiert wird.
Gibt es sowas doch standardmässig (ich habe nichts gefunden)?
Ein Workaround mit Formeln (ich will keine Extraspalte anlegen)?
Wenn möglich keine VBA Lösung.

Danke im Voraus für Eure Hilfe

Gruss
Gunnar

Bild


Betrifft: AW: SUMMENDIVISION ?!
von: M@x
Geschrieben am: 31.10.2003 11:11:13

Hi Gunnar,
=SUMMENPRODUKT((A10:A100)/(B10:B100))

Gruss

M@x


Bild


Betrifft: Fehler bei =SUMMENPRODUKT((A10:A100)/(B10:B100))
von: Gunnar
Geschrieben am: 31.10.2003 11:38:05

Hallo M@x,

danke für die Hilfe.
Leider liefert mir diese Formel eine Fehlermeldung (ähm, ich glaube #DIV/0, obowohl in allen Zellen Werte >1 stehen).
Liegt das an meiner Excel Version (2000)?
Andere Lösungsvorschläge?

Danke schon mal.

Gunnar


Bild


Betrifft: AW: Fehler bei =SUMMENPRODUKT((A10:A100)/(B10:B100
von: M@x
Geschrieben am: 31.10.2003 12:00:51

Hi Gunnar,

ja diese Fhlermeldung ist ja klar,
muß ich mir noch überlegen wie man daß mit Wennabfrage oder Istfehler abfangen kann.
bis später, vielleicht kommen dazwischen auch die Heinzelmännchen.

Gruss

M@x


Bild


Betrifft: AW: Fehler bei =SUMMENPRODUKT((A10:A100)/(B10:B100
von: Nadja
Geschrieben am: 31.10.2003 12:19:27

Juhu, das Heinzelmännchen ist hier...

4/2 ist dasselbe wie 4*1/2 ... daher die einfache Formel
=SUMMENPRODUKT((A1:A10);(1/B1:B10)) verwenden und du addierst die einzelnen dividierten Werte, ne?

Liebe Grüße
Nadja.


Bild


Betrifft: AW: Fehler bei =SUMMENPRODUKT((A10:A100)/(B10:B100
von: Gunnar
Geschrieben am: 31.10.2003 13:46:28

Hallo Nadja und M@x und alle anderen, die mitlesen und helfen wollen,

=SUMMENPRODUKT((A1:A10);(1/B1:B10)) geht leider auch nicht, auch =SUMMENPRODUKT((A1:A10);(B1:B10^-1)) nicht. Da aber andere Möglichen Operationen möglich sind, zB *, + etc., vermute ich, dass Excel die 1/ bzw. ^-1 einfach nicht zulässt, um eine mögliche Division durch 0 zu verhindern; daher auch die Fehlermeldung #DIV/0! (was auch schon M@x wohl vermutet hat?).
Wird mir wohl nichts anderes übrigbleiben, eine zusätzliche Spalte einzubauen :-(.

Auf jedenfall vielen Dank an Heinzelmännchen Nadja und M@x und alle, die sich Gedanken gemacht haben. Aber wenn noch jemandem was einfalles sollte, nur her damit :-)

Gruss
Gunnar


Bild


Betrifft: YIPIIEH
von: Gunnar
Geschrieben am: 31.10.2003 14:23:59

So,

habe das Problem gelöst (und fühle mich wie ein kleiner Held)!
=summe(A1:A10/B1:B10) und mit STRG-UMSCHALT-ENTER abschliessen, damit es eine Matrixformel ist, et voilà!

Vielleicht hilft es einem von Euch später mal.

Ciao
Gunnar


Bild


Betrifft: AW: YIPIIEH ? -:((
von: M@x
Geschrieben am: 31.10.2003 18:34:49

Hi Gunnar,
das versteh ich jetzt aber nicht, sobald ein B1:10 den Wert 0 annimmt, kommt doch auch hier die Fehlermeldung #DIV/0!

Die Formel Summenprodukt((A1:A10)/(B1:B10))
und die Formel {SUMME((A1:A10)/(B1:B10))}
sind beides Arrayformeln und reagieren auch gleich

Gruß

M@x


Bild


Betrifft: AW: YIPIIEH ? -:((
von: Gunnar
Geschrieben am: 03.11.2003 09:46:13

Hallo M@x,

=Summenprodukt((A1:A10)/(B1:B10)) ergibt bei mir automatisch den Fehlerwert #DIV/0!, auch wenn alle Zellen in B1:B10 ungleich 0 sind.
{=summe(A1:A10/B1:B10)} ergibt nur dann den Fehlerwert #DIV/0!, falls wirklich 0 in einer Zelle in B1:B10 steht, zudem kann man dieses ja vorher mit einer Bedingung abfangen.
Und jetzt kommt noch hinzu, dass sich Matrixformeln (zumindest diese) nicht auf verbundene Zellen anwenden lassen...

Ciao
Gunnar


 Bild

Beiträge aus den Excel-Beispielen zum Thema " Ausdruck auf einem Blatt"