sverweis- mehrfachdaten

Bild

Betrifft: sverweis- mehrfachdaten
von: Harald
Geschrieben am: 01.11.2003 17:45:14

Hallo,

Ich möchte aufgrund des in dpd stehenden Datums eine Abfrage in einem anderen
Tabellenblatt durchführen. Da dieses Datum in "rufa" mehrfach vorkommt, funktioniert dies nicht mit allen gefundenen Datensätzen.

Wer kann helfen?

Danke und Gruß
Harald
https://www.herber.de/bbs/user/1706.xls

Bild


Betrifft: AW: sverweis- mehrfachdaten
von: Hajo_Zi
Geschrieben am: 01.11.2003 17:52:23

Hallo Harald

suche mal auf folgender Seite

http://www.excelformeln.de/uberuns.html


Bitte keine Mail, Probleme sollten im Forum gelöst werden.

Microsoft MVP für Excel

Das Forum lebt auch von den Rückmeldungen.




Bild


Betrifft: AW: sverweis- mehrfachdaten
von: th.heinrich
Geschrieben am: 01.11.2003 21:31:13

hallo Harald,

in DPD B2 steht.

=WENN(ISTFEHLER(SVERWEIS($A$24;Rufa!$A2:$H2;3;FALSCH));"";SVERWEIS($A$24;Rufa!$A2:$H2;3;FALSCH))

und runterkopieren.

gruss thomas


Bild


Betrifft: AW: sverweis- mehrfachdaten
von: PeterW
Geschrieben am: 01.11.2003 21:35:08

Hallo Thomas,

mit diesem Ansatz findest du MEHRERE Fundstellen? ;-)

Gruß
Peter


Bild


Betrifft: AW: sverweis- mehrfachdaten
von: th.heinrich
Geschrieben am: 01.11.2003 22:22:25

hi Peter,

schoen wieder von Dir zu lesen.

habe es getestet und bei mehrfach gleichem datum wird jeweils nur ein empfaenger ausgegeben.

gruss thomas

ps. mache jetzt gen heija, muss morgen frueh raus.


Bild


Betrifft: AW: sverweis- mehrfachdaten
von: Harald
Geschrieben am: 02.11.2003 09:52:35

Danke Thomas,

Funktioniert grundsätzlich, aber die gefundenen Daten sollten auf
DPD dann in der ersten bis vieviel immer gefundene Stellen (Zeilen) stehen.

Gruß
Harald


Bild


Betrifft: AW: sverweis- mehrfachdaten
von: harald
Geschrieben am: 02.11.2003 14:25:38

Hallo Thomas, hallo Peter,


Ich habs geschafft! Bin deshalb als "nicht Profi" stolz.

Hier die Lösung:=WENN(ZEILE($A1)>ZÄHLENWENN(Rufa!$A:$A;DPD!$A$24);"";INDEX(Rufa!B:B;KKLEINSTE(WENN((Rufa!$A$2:$H$1000=DPD!$A$24);ZEILE($2:$1000));ZEILE(A1))))
steht in A2 zum runterkopieren. Die Suche für die übrigen Spalten habe ich
entsprechend angepasst.

Gruß und nochmals Danke
Harald



Bild


Betrifft: gratuliere u. danke fuer die rueckmeldung ot.
von: th.heinrich
Geschrieben am: 02.11.2003 19:35:16

.


 Bild

Beiträge aus den Excel-Beispielen zum Thema " sverweis- mehrfachdaten"