INDEX-Funktion

Bild

Betrifft: INDEX-Funktion
von: Raffi
Geschrieben am: 05.11.2003 15:45:28

Hallo alle miteinander

Benutze in Zelle "A2" folgende Funktion in Excel:
=WENN(A1="Alarm!";INDEX(C:C;VERGLEICH("Alarm!";N:N;0);1);"ok")

Diese überprüft ob in A1 Alarm! steht. Wenn dies so ist, wird in Spalte N gesucht, wo dieser Wert steht und ein Wert aus Spalte C zurückgegeben.

Nun möchte ich, dass wenn ein weiterer Wert dieses Kriterium erfüllt dieser in Zelle A2 steht. Also der letzte Wert. Dies funktioniert jedoch nur, wenn der neue Wert "Alarm!" in der Spalte oberhalb des vorhergehenden steht.

Gibt es eine Funktion, mit welcher einfach immer der letzte Wert der das Kriterium erfüllt, angezeigt wird.


Besten Dank und Gruss
raffi

Bild


Betrifft: Mit VERGLEICH letzten Treffer ermitteln
von: Boris
Geschrieben am: 05.11.2003 15:52:30

Hi Raffi,

folgende Array-Formel erledigt das:

{=WENN(A1="Alarm!";INDEX(C:C;MAX((N1:N1000="Alarm!")*ZEILE(1:1000)));"o.k.")}

{geschweifte Klammern} nicht mit eingeben, sondern Formeleingabe mit Strg-Shift-Enter abschließen. Das erzeugt sie.

Grüße Boris


Bild


Betrifft: AW: Mit VERGLEICH letzten Treffer ermitteln
von: Raffi
Geschrieben am: 05.11.2003 16:11:30

Hallo Boris,

besten Dank für deine Hilfe. Leider funktioniert das immer noch nicht ganz. Es ergibt einen #DIV/0! Fehler.

Vielleicht muss ich erwähnen dass der Wert Alarm! In Zelle A1 auch bereits aus einer WENN-Formel herrührt:
=WENN(ISTNV(VERGLEICH("Alarm!";N:N;0));"Alarm";"Alarm!")

Wo könnte denn der Hund vergrabe sein?

Gruss
raffi


Bild


Betrifft: Dann enthält die Suchspalte "N:N" Fehlerwerte...
von: Boris
Geschrieben am: 05.11.2003 20:27:44

Hi Raffi,

...entferne diese - und alles wird gut;-))

Grüße Boris


Bild


Betrifft: AW: Dann enthält die Suchspalte "N:N" Fehlerwerte...
von: Raffi
Geschrieben am: 06.11.2003 16:06:46

Richtig, habe die Fehlerwerte eliminiert. Nun funktioniert die Formel. Jedoch nicht so, wie ich es mir gewünscht hätte. Sie liefert nun immer den letzten Wert in der Spalte (der unterste Wert) der das Kriterium erfüllt. Gibt es eine Möglichkeit, dass der aktuellste Wert (sprich: Der Wert der das Kriterium zeitlich zuletzt erfüllt hat) ausgegeben wird.

Vielen Dank und Gruss aus der Schweiz
Raffi


Bild


Betrifft: AW: Dann enthält die Suchspalte "N:N" Fehlerwerte...
von: Boris
Geschrieben am: 06.11.2003 22:31:29

Hi Raffi,

deine Eingangsfrage lautete:

"Gibt es eine Funktion, mit welcher einfach immer der letzte Wert der das Kriterium erfüllt, angezeigt wird."

Da war noch nix von Zeit die Rede.

Wo stehen denn Datümer? In welcher Spalte? Poste doch mal kurz ne kleine Beispieltabelle, dann wird´s einfacher.

Grüße Boris


Bild


Betrifft: AW: Dann enthält die Suchspalte "N:N" Fehlerwerte...
von: Raffi
Geschrieben am: 07.11.2003 10:13:30

Hi Boris,

Sorry, mein Fehler! Meinte eigentlich den zeitlich letzten - sprich: den aktuellsten - Wert. Habs falsch formuliert.
Habe die Datei, an der ich arbeite raufgeladen (sh. URL ganz unten). Es handelt sich dabei um eine Kursliste. Die Kurse der Aktien werden über DDE-Links aus dem Kursinformationssystem Telekurs gespiesen. sobald ein bezahlter Kurs einen eine obere oder untere marke erreicht, soll Alarm! ausgegeben werden. In Zelle A2 möchte ich dann den Titel der dieses Kriterium zuletzt erfüllt hat. Sobald sich dieser ändert wird per Makro eine Mail an bestimmte Personen versandt.

Wäre toll wenn du mir dabei helfen könntest.

Dank und Gruss
raffi

https://www.herber.de/bbs/user/1793.xls


Bild

Beiträge aus den Excel-Beispielen zum Thema " letzter Eintrag"