Doppelte Datensätze kopieren

Bild

Betrifft: Doppelte Datensätze kopieren
von: Burghard
Geschrieben am: 06.11.2003 14:51:03

Hallo,

ich brauche mal wieder Hilfe. Bei meinem Makro werden doppelte Datensätze markiert (rote Textfarbe) und anschließend sollen die Zellen mit roter Textfarbe (die ganze Zeile) von Tabelle1 nach Tabelle2 kopiert werden.

Diese Fehler würde ich gerne ausmerzen:

1. Es werden nicht alle doppelten Datensätze mit roter Textfarbe markiert (von 3 gleichen werden zwei mit roter Textfarbe markiert, der dritte bleibt schwarz), es sollen aber alle drei mit roter Schrift versehen werden.

2. Das Rüberkopieren der Zeilen klappt nicht nach Tabelle2. Hängt wohl irgendwie mit der bedingten Formatierung zusammen.

Hilfe wäre super! Danke im voraus.

Gruß Burghard



Sub Doppelte_kopieren()
Columns("A:A").Select
Selection.FormatConditions.Delete
Selection.FormatConditions.Add Type:=xlExpression, Formula1:= _
"=ZÄHLENWENN(A$1:A1;A2)>=1"
Selection.FormatConditions(1).Font.ColorIndex = 3
Dim Zelle As Range: Zeile = 0
For Each Zelle In Worksheets("Tabelle1").UsedRange
If Zelle.Font.ColorIndex = 3 Then
Worksheets("Tabelle1").Select
Rows(Zelle.Row & ":" & Zelle.Row).Select
Selection.Copy
Zeile = Zeile + 1
Sheets("Tabelle2").Select
Range("A" & Zeile).Select
ActiveSheet.Paste
End If
Next Zelle
End Sub

Bild


Betrifft: AW: Doppelte Datensätze kopieren
von: GerdW
Geschrieben am: 06.11.2003 15:03:57

Die Farben von bedingten Formatierungen lassen sich so nicht abfragen,
nur "normale" Farben.

Gerd


Bild


Betrifft: AW: Doppelte Datensätze kopieren
von: Burghard
Geschrieben am: 06.11.2003 21:01:48

Vielen Dank für die Info! Puh, weißt Du eine andere Lösung?


Bild

Beiträge aus den Excel-Beispielen zum Thema " Doppelte Datensätze kopieren"