ODER in FINDEN funktion

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
MsgBox
Bild

Betrifft: ODER in FINDEN funktion
von: helge
Geschrieben am: 08.11.2003 14:47:01

Hallo,
ich suche eine lösung in vba für
FINDEN("/";A1)
problem ist der "/" kann auch manchmal ein anderes Zeichen sein
gibt es da sowas wie
FINDEN("/" Or "§";A1) ???

danke

helge

Bild


Betrifft: AW: ODER in FINDEN funktion
von: Hajo_Zi
Geschrieben am: 08.11.2003 15:28:26

Hallo Helge

der VBA Befehl ist Instr. Aber die Suche mußt Du nach jedem Zeichen einzeln vornehmen.


Bitte keine Mail, Probleme sollten im Forum gelöst werden.

Microsoft MVP für Excel

Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Pro und Excel Version XP Pro




Bild


Betrifft: AW: ODER in FINDEN funktion
von: Reinhard
Geschrieben am: 08.11.2003 19:56:01

Hi Helge,
entweder in Excel:
=WENN(FINDEN("/";A1)<FINDEN("$";A1);FINDEN("/";A1);FINDEN("$";A1))
oder in VBA:

Sub t()
Dim Ergebnis As Integer
If InStr([A1], "/") < InStr([A1], "$") Then
    Ergebnis = InStr([A1], "/")
Else
    Ergebnis = InStr([A1], "$")
End If
MsgBox Ergebnis
End Sub

Gruß
Reinhard


Bild

Beiträge aus den Excel-Beispielen zum Thema " ODER in FINDEN funktion"