Dateigröße wegen Formelwiederholungen

Bild

Betrifft: Dateigröße wegen Formelwiederholungen
von: Lorenz Korsalka
Geschrieben am: 08.11.2003 14:27:25

Hilfe ! Datei wird riesengross!
Bin schon bei 17MB angelangt!
Wie kann ich bei Formelwiederholungen die "selbe" oder ev. "benannte" wiederverwenden!
Wie soll so etwas ausschauen, oder mit welcher FUNKTION kann`s gemacht werden.
Hab's mit INDIREKT probiert aber leider ohne Erfolg!

Da anschließende Musterformel schon relativ groß ist, kann man sich vorstellen wie enorm die Dateigröße werden wird
Ich verwende unter anderem solche od. ähnliche verschachtelungen und Formeln :

"=WENN(SoFt=0;FZ6*24;SUMME((UND(UND(ODER(D6=1;TEXT(Q6;"HH:MM")="06:00");TEXT(E6;"HH:MM")="06:00";TEXT(F6;"HH:MM")="06:30");NICHT(Art1="Schnee")))*0,5;(UND(UND(ODER(D6=1;TEXT(Q6;"HH:MM")="06:00");TEXT(E6;"HH:MM")="06:00";TEXT(F6;"HH:MM")="07:00");NICHT(Art1="Schnee")))*1;UND(UNTERGRENZE(WENN(ODER(UND(N6=1;N6="I";TEXT(L6;"HH:MM")="22:00");ODER(N6=1;N6="I");ODER(TEXT(P6;"HH:MM")="22:00";TEXT(S6;"HH:MM")="22:00"));GC6*24;0);3);NICHT(Art4="Schnee"));FZ6*24))"

und oder

"=WENN(TEXT($B$1;"TTTT")="Samstag";0;WENN(UND(TEXT($B$1;"TTTT")="Montag";INDIREKT("'"&TEXT($B$1;"T")-1&".'!"&"N"&ZEILE())=0);INDIREKT("'"&TEXT($B$1;"T")-3&".'!"&"N"&ZEILE());INDIREKT("'"&TEXT($B$1;"T")-1&".'!"&"N"&ZEILE())))"

in einem Blatt von Zeile 6 bis Zeile 89 und das Ganze in 31 Sheets mit dem Namen "1., 2., 3. usw. bis 31."

Danke im voraus Lorenz!

Bild


Betrifft: AW: Dateigröße wegen Formelwiederholungen
von: N. Davidheimann
Geschrieben am: 08.11.2003 14:38:25

Hallo Lorenz,

villeicht hilft Dir weiter, daß in Excel ein Name nicht nur für einen Bereich vergeben werden kann, sondern auch für eine Formel.Über Einfügen >>Name >> Definieren >> Bezieht sich auf: kannst Du auch Formeln eingeben.

Gruß
Norbert


Bild


Betrifft: AW: Dateigröße wegen Formelwiederholungen
von: Lorenz K.
Geschrieben am: 08.11.2003 15:05:41

Hallo Norbert!
Danke für´n TIPP
aber wenn ich z. B. die zweite Formel als benannte Formel verwende,
so ergibt es immer #WERT


Bild

Beiträge aus den Excel-Beispielen zum Thema " Doppelte Datensätze markieren"