VBA oder Sverweis?

Bild

Betrifft: VBA oder Sverweis?
von: UlliH
Geschrieben am: 18.11.2003 12:07:28

Hallo ich habe da ein mitleres Problem.
Gegeben ist eine Excel-Datei mit mehreren Tabellenblättern. In "Tabelle6" werden in den Spalten A und B Werte eingegeben.
In "Tabelle2" sollen die in Spalte C eingegebenen Werte mit den Einträgen in "Tabelle6 / Spalte A" verglichen werden und bei Übereinstimmung der Wert aus "Tabelle6 / Spalte B" in "Tabelle2 / Spalte G" ausgegeben werden.

Ich dachte, das ist mit einem normalen SVerweis machbar. Solange eine Übereinstimmung gefunden wird, erfolgt auch der Eintrag in "Tabelle2 / Spalte G". Wenn keine Übereinstimmung herrscht bzw. die Zeilen leer sind, kommt #NV.
Wie kann man es lösen, dass dieses #NV nicht erscheint?

Vielen Dank im Voraus

UlliH

Bild


Betrifft: AW: Wenn(IstFehler(....
von: Galenzo
Geschrieben am: 18.11.2003 12:20:46

Hallo,
bastle um deine SVERWEIS-Funktion noch eine WENN-Abfrage drumherum, welche auf Fehler prüft (ISTFEHLER). z.B.:
=WENN(ISTFEHLER(SVERWEIS(D1;A1:B7;1));"Nicht gefunden";SVERWEIS(D1;A1:B7;1))

Viel Erfolg!


Bild


Betrifft: AW: Wenn(IstFehler(....
von: UlliH
Geschrieben am: 18.11.2003 13:10:41

Vielen Dank, es hat super geklappt. Es hat mir mal wieder gezeigt, dass man vorher doch noch mal nachdenken sollte. Trotzdem Vielen Dank nochmal

Viele Grüße
UlliH


Bild

Beiträge aus den Excel-Beispielen zum Thema " VBA oder Sverweis?"