Formel

Bild

Betrifft: Formel
von: Stefan Kösters
Geschrieben am: 19.11.2003 15:58:11

Hallo,
habe ein kleines Problem. Vielleicht kann mir ja jemand helfen. Wie lautet die Formel für folgenden Sachverhalt (in einer Spalte):
0-3000 müsste mit 20 multipliziert werden, falls die Summe der Zellen zwischen 3000 und 10000 liegt, dann mit 17,50 (die ersten 3000 aber mit 20) und wenn die Summe über 10000 ist, dann mit 15 (die ersten 3000 mit 20, 3000 bis 10000 mit 17,50).
Vielen Dank
Stefan

Bild


Betrifft: AW: Formel
von: Bernd Kiehl
Geschrieben am: 19.11.2003 16:14:07

Hallo Stefan,

meinst du so ...

Gruss Bernd

Tabelle1
 AB
110000150000
Formeln der Tabelle
B1 : =WENN(A1>=10000;A1*15;WENN(A1>=3000;A1*17,5;WENN(A1<=3000;A1*20;"")))
 
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Bild


Betrifft: AW: Formel
von: Stefan Kösters
Geschrieben am: 19.11.2003 16:25:03

Vielen Dank für die Hilfe. Gruß Stefan


Bild


Betrifft: Danke für die Rückmeldung - OT
von: Bernd Kiehl
Geschrieben am: 19.11.2003 16:26:53

.


Bild


Betrifft: AW: =MIN(A1;3000)*20+MIN(7000;MAX(0;A1-3000))*17,5
von: FP
Geschrieben am: 19.11.2003 20:20:00

Hallo Stefan,

hier der Beweis:
in Spalte B steht die Formel von Boris
in Spalte C die Formel lt. Betreff

Excel Jeanie HTML
Formeln der Tabelle
B1 : =WENN(A1<=3000;A1*20;WENN(A1<=10000;3000*20+(A1-3000)*17,5;3000*20+7000*17,5+(A1-10000)*15))
C1 : =MIN(A1;3000)*20+MIN(7000;MAX(0;A1-3000))*17,5+MAX(0;A1-10000)*15
B2 : =WENN(A2<=3000;A2*20;WENN(A2<=10000;3000*20+(A2-3000)*17,5;3000*20+7000*17,5+(A2-10000)*15))
C2 : =MIN(A2;3000)*20+MIN(7000;MAX(0;A2-3000))*17,5+MAX(0;A2-10000)*15
B3 : =WENN(A3<=3000;A3*20;WENN(A3<=10000;3000*20+(A3-3000)*17,5;3000*20+7000*17,5+(A3-10000)*15))
C3 : =MIN(A3;3000)*20+MIN(7000;MAX(0;A3-3000))*17,5+MAX(0;A3-10000)*15
B4 : =WENN(A4<=3000;A4*20;WENN(A4<=10000;3000*20+(A4-3000)*17,5;3000*20+7000*17,5+(A4-10000)*15))
C4 : =MIN(A4;3000)*20+MIN(7000;MAX(0;A4-3000))*17,5+MAX(0;A4-10000)*15
B5 : =WENN(A5<=3000;A5*20;WENN(A5<=10000;3000*20+(A5-3000)*17,5;3000*20+7000*17,5+(A5-10000)*15))
C5 : =MIN(A5;3000)*20+MIN(7000;MAX(0;A5-3000))*17,5+MAX(0;A5-10000)*15
B6 : =WENN(A6<=3000;A6*20;WENN(A6<=10000;3000*20+(A6-3000)*17,5;3000*20+7000*17,5+(A6-10000)*15))
C6 : =MIN(A6;3000)*20+MIN(7000;MAX(0;A6-3000))*17,5+MAX(0;A6-10000)*15
B7 : =WENN(A7<=3000;A7*20;WENN(A7<=10000;3000*20+(A7-3000)*17,5;3000*20+7000*17,5+(A7-10000)*15))
C7 : =MIN(A7;3000)*20+MIN(7000;MAX(0;A7-3000))*17,5+MAX(0;A7-10000)*15
B8 : =WENN(A8<=3000;A8*20;WENN(A8<=10000;3000*20+(A8-3000)*17,5;3000*20+7000*17,5+(A8-10000)*15))
C8 : =MIN(A8;3000)*20+MIN(7000;MAX(0;A8-3000))*17,5+MAX(0;A8-10000)*15
B9 : =WENN(A9<=3000;A9*20;WENN(A9<=10000;3000*20+(A9-3000)*17,5;3000*20+7000*17,5+(A9-10000)*15))
C9 : =MIN(A9;3000)*20+MIN(7000;MAX(0;A9-3000))*17,5+MAX(0;A9-10000)*15
B10 : =WENN(A10<=3000;A10*20;WENN(A10<=10000;3000*20+(A10-3000)*17,5;3000*20+7000*17,5+(A10-10000)*15))
C10 : =MIN(A10;3000)*20+MIN(7000;MAX(0;A10-3000))*17,5+MAX(0;A10-10000)*15
B11 : =WENN(A11<=3000;A11*20;WENN(A11<=10000;3000*20+(A11-3000)*17,5;3000*20+7000*17,5+(A11-10000)*15))
C11 : =MIN(A11;3000)*20+MIN(7000;MAX(0;A11-3000))*17,5+MAX(0;A11-10000)*15
B12 : =WENN(A12<=3000;A12*20;WENN(A12<=10000;3000*20+(A12-3000)*17,5;3000*20+7000*17,5+(A12-10000)*15))
C12 : =MIN(A12;3000)*20+MIN(7000;MAX(0;A12-3000))*17,5+MAX(0;A12-10000)*15
B13 : =WENN(A13<=3000;A13*20;WENN(A13<=10000;3000*20+(A13-3000)*17,5;3000*20+7000*17,5+(A13-10000)*15))
C13 : =MIN(A13;3000)*20+MIN(7000;MAX(0;A13-3000))*17,5+MAX(0;A13-10000)*15
B14 : =WENN(A14<=3000;A14*20;WENN(A14<=10000;3000*20+(A14-3000)*17,5;3000*20+7000*17,5+(A14-10000)*15))
C14 : =MIN(A14;3000)*20+MIN(7000;MAX(0;A14-3000))*17,5+MAX(0;A14-10000)*15
B15 : =WENN(A15<=3000;A15*20;WENN(A15<=10000;3000*20+(A15-3000)*17,5;3000*20+7000*17,5+(A15-10000)*15))
C15 : =MIN(A15;3000)*20+MIN(7000;MAX(0;A15-3000))*17,5+MAX(0;A15-10000)*15
B16 : =WENN(A16<=3000;A16*20;WENN(A16<=10000;3000*20+(A16-3000)*17,5;3000*20+7000*17,5+(A16-10000)*15))
C16 : =MIN(A16;3000)*20+MIN(7000;MAX(0;A16-3000))*17,5+MAX(0;A16-10000)*15
B17 : =WENN(A17<=3000;A17*20;WENN(A17<=10000;3000*20+(A17-3000)*17,5;3000*20+7000*17,5+(A17-10000)*15))
C17 : =MIN(A17;3000)*20+MIN(7000;MAX(0;A17-3000))*17,5+MAX(0;A17-10000)*15
B18 : =WENN(A18<=3000;A18*20;WENN(A18<=10000;3000*20+(A18-3000)*17,5;3000*20+7000*17,5+(A18-10000)*15))
C18 : =MIN(A18;3000)*20+MIN(7000;MAX(0;A18-3000))*17,5+MAX(0;A18-10000)*15
B19 : =WENN(A19<=3000;A19*20;WENN(A19<=10000;3000*20+(A19-3000)*17,5;3000*20+7000*17,5+(A19-10000)*15))
C19 : =MIN(A19;3000)*20+MIN(7000;MAX(0;A19-3000))*17,5+MAX(0;A19-10000)*15
B20 : =WENN(A20<=3000;A20*20;WENN(A20<=10000;3000*20+(A20-3000)*17,5;3000*20+7000*17,5+(A20-10000)*15))
C20 : =MIN(A20;3000)*20+MIN(7000;MAX(0;A20-3000))*17,5+MAX(0;A20-10000)*15
B21 : =WENN(A21<=3000;A21*20;WENN(A21<=10000;3000*20+(A21-3000)*17,5;3000*20+7000*17,5+(A21-10000)*15))
C21 : =MIN(A21;3000)*20+MIN(7000;MAX(0;A21-3000))*17,5+MAX(0;A21-10000)*15
B22 : =WENN(A22<=3000;A22*20;WENN(A22<=10000;3000*20+(A22-3000)*17,5;3000*20+7000*17,5+(A22-10000)*15))
C22 : =MIN(A22;3000)*20+MIN(7000;MAX(0;A22-3000))*17,5+MAX(0;A22-10000)*15
B23 : =WENN(A23<=3000;A23*20;WENN(A23<=10000;3000*20+(A23-3000)*17,5;3000*20+7000*17,5+(A23-10000)*15))
C23 : =MIN(A23;3000)*20+MIN(7000;MAX(0;A23-3000))*17,5+MAX(0;A23-10000)*15
B24 : =WENN(A24<=3000;A24*20;WENN(A24<=10000;3000*20+(A24-3000)*17,5;3000*20+7000*17,5+(A24-10000)*15))
C24 : =MIN(A24;3000)*20+MIN(7000;MAX(0;A24-3000))*17,5+MAX(0;A24-10000)*15
B25 : =WENN(A25<=3000;A25*20;WENN(A25<=10000;3000*20+(A25-3000)*17,5;3000*20+7000*17,5+(A25-10000)*15))
C25 : =MIN(A25;3000)*20+MIN(7000;MAX(0;A25-3000))*17,5+MAX(0;A25-10000)*15
B26 : =WENN(A26<=3000;A26*20;WENN(A26<=10000;3000*20+(A26-3000)*17,5;3000*20+7000*17,5+(A26-10000)*15))
C26 : =MIN(A26;3000)*20+MIN(7000;MAX(0;A26-3000))*17,5+MAX(0;A26-10000)*15
B27 : =WENN(A27<=3000;A27*20;WENN(A27<=10000;3000*20+(A27-3000)*17,5;3000*20+7000*17,5+(A27-10000)*15))
C27 : =MIN(A27;3000)*20+MIN(7000;MAX(0;A27-3000))*17,5+MAX(0;A27-10000)*15
B28 : =WENN(A28<=3000;A28*20;WENN(A28<=10000;3000*20+(A28-3000)*17,5;3000*20+7000*17,5+(A28-10000)*15))
C28 : =MIN(A28;3000)*20+MIN(7000;MAX(0;A28-3000))*17,5+MAX(0;A28-10000)*15
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download   Servus aus dem Salzkammergut Franz

Bild


Betrifft: =A1*VERWEIS(A1;{0;3000;10000};{20;17,5;15})
von: WF
Geschrieben am: 19.11.2003 16:28:55

.


Bild


Betrifft: AW: =A1*VERWEIS(A1;{0;3000;10000};{20;17,5;15})
von: Stefan Kösters
Geschrieben am: 19.11.2003 16:30:58

Hört sich auch gut an. Probier ich auch mal aus. Klappt ja echt bombig. hab so ein Forum das 1.mal ausprobiert. Vielen Dank. Gruß Stefan


Bild


Betrifft: Sorry, Meister - aber hier liegst du falsch...
von: Boris
Geschrieben am: 19.11.2003 16:39:59

Hi Walter,

...denn bei 15000 sollen die ersten 3000 dennoch mit 20, die nächsten 7000 mit 17,5 und dann erst mit 15 multipliziert werden.

Grüße Boris


Bild


Betrifft: AW: Sorry, Meister - aber hier liegst du falsch...
von: Stefan Kösters
Geschrieben am: 19.11.2003 16:44:36

Stimmt Boris, Du hast recht. Bei den bisher angegebenen Formel werden die darunterliegenden Zahlen auch mit dem neuen Wert multipliziert. Hat jemand eine Lösung?
Grüße und Dank. Stefan


Bild


Betrifft: Auf die Schnelle...
von: Boris
Geschrieben am: 19.11.2003 17:00:46

Hi Stefan,

...eine "gruselige" WENN-Verschachtelung (ich hasse WENN ...):

=WENN(A1<=3000;A1*20;WENN(A1<=10000;3000*20+(A1-3000)*17,5;3000*20+7000*17,5+(A1-10000)*15))

Grüße Boris


Bild


Betrifft: =A1*20-MAX(0;A1-3000)*2,5-MAX(0;A1-10000)*2,5
von: IngoG
Geschrieben am: 19.11.2003 16:59:51

Hallo Stefan,

obige formel sollte funzen

Gruß Ingo

PS Eine Rückmeldung wäre nett...


Bild


Betrifft: AW: =A1*20-MAX(0;A1-3000)*2,5-MAX(0;A1-10000)*2,5
von: Stefan Kösters
Geschrieben am: 19.11.2003 18:00:52

Irgendwie raff´s ich nicht. warum mit 2,5 multiplizieren?
Gruß Stefan


Bild


Betrifft: Das sind nur die Abzüge...
von: Boris
Geschrieben am: 19.11.2003 18:03:05

Hi Stefan,

...weil zu Beginn ja A1 komplett mit 20 multipliziert wird - und die Staffelungen 20 - 17,5 - 15 sind immer in 2,5-Schritten.

Grüße Boris


Bild


Betrifft: AW: Das sind nur die Abzüge...
von: Stefan Kösters
Geschrieben am: 19.11.2003 18:04:36

oh mann, ein informatik-ass ist an mir ja nicht verloren gegangen. vielen dank. gruß stefan


Bild


Betrifft: AW: Das sind nur die Abzüge...
von: Stefan Kösters
Geschrieben am: 19.11.2003 18:09:51

Jetzt funkts. Dank an Boris.


Bild


Betrifft: AW: Super !!! ...
von: FP
Geschrieben am: 19.11.2003 20:36:47

Hallo Ingo,

Super Formel!

Obwohl ich aus Gründen der Nachvollziehbarkeit folgende Version bevorzugen würde:

=A1*20-MAX(;A1-3000)*(20-17,5)-MAX(;A1-10000)*(17,5-15)

Servus aus dem Salzkammergut
Franz


Bild


Betrifft: Danke für dir Rückmeldung oT
von: IngoG
Geschrieben am: 20.11.2003 01:30:43

.


Bild

Beiträge aus den Excel-Beispielen zum Thema " Formel"