Zählfunktion

Bild

Betrifft: Zählfunktion
von: Friedrich
Geschrieben am: 26.11.2003 07:58:47

Hallo und guten Morgen,

ich habe in den Spalten A9:A39 Datumswerte stehen. Immer von A9 ausgehend mit dem 1. eines jeweiligen Monats. Entsprechend sind dann nicht alle Zellen bis A39 mit Werten belegt.
In der Spalte B steht zum entsprechenden Datum in A der Wochentag (Mo/Di/Mi usw.).
Auf dem Blatt "Kalender" stehen im benannten Bereich "Feiertag" alle Feiertage (incl. 24.12. und 31.12.).
Die Zellen in A und B, die "Sa", "So" sind und in "Feiertag" liegen, werden über bedingte Formatierung anderst eingefärbt.
Das klappt soweit so gut. Ich möchte jetzt im Bereich A9:A39 alle Zellen zählen, die "Sa", "So" sind im Bereich Feiertag liegen (keine Doppelzählung wenn Sa oder So = Feiertag) und die leer sind (wenn Monat zB. nur 28/29 oder 30 Tage hat).
Von 31 soll dieses Ergebnis abgezogen werden und mit 8,2 multipliziert werden.

Lange Rede kurzer Sinn: Ich möchte pro Monat nur die Arbeitstage ermitteln, wobei der 24.12. und 31.12. ebenfall wie ein Feiertag behandelt werden sollen.

Diese Formel rechnet nicht korrekt, da Doppelzählung!

=SUMME(WENN(ISTFEHLER(SUCHEN("SA";B9:B39));;1))+SUMME(WENN(ISTFEHLER(SUCHEN("SO";B9:B39));;1))+SUMME(WENN(ISTFEHLER(SUCHEN("0";B9:B39));;1))+SUMME(WENN(ISTFEHLER(SUCHEN(A9:A39;Feiertag));;1))


mfG Friedrich

Bild


Betrifft: AW: Zählfunktion
von: OttoH
Geschrieben am: 26.11.2003 09:01:29

Hallo Friedrich,

mach's nicht so kompliziert. Die Funktion NETTOARBEITSTAGE ermittelt den korrekten Wert.

Stelle einfach eine Liste mit allen Feiertagen zusammen (feste wie bewegliche und auch firmenspezifische).
Dann brauchst Du den Anfangswert (1. des Monats ) und den Endwert ( letzter des Monats )
und die Liste mit den Feiertagsdaten. Schau' Dir die Hilfestellung zur Funktion an.

Bei weiteren Rückfragen melde dich nochmal.

Gruß OttoH


Bild

Beiträge aus den Excel-Beispielen zum Thema " Funktion RENDITEDIS in englisch"