brauche Hilfe zum wiederholten Prozentabzug

Bild

Betrifft: brauche Hilfe zum wiederholten Prozentabzug
von: Excelmaus
Geschrieben am: 26.11.2003 21:09:54

Hallo User,

Habe euer Forum beim Stöbern im Netz gefunden.
Ich wollte gerade eine Formel konstruieren, komme aber nicht weiter.
vielleicht kann mir ja einer von euch weiter helfen.

Und zwar möchte ich von einem Wert x y mal z% vom Ergebnis abziehen.

z.B. ist die Eingabe x=1000 y=4 z=10

Das Ergebnis muss 656,1 sein.

d.h. 1000 - 10% = 900
900 - 10% = 810
810 - 10% = 729
729 - 10% = 656,1

So, ich hoffe nun, dass mir einer von euch helfen kann.

Vielen Dank im Voraus
Grüße von Excelmaus

Bild


Betrifft: AW: brauche Hilfe zum wiederholten Prozentabzug
von: K.Rola
Geschrieben am: 26.11.2003 21:25:50

Hallo,

kleine UDF:

Option Explicit

Function xProzent(Wert As Double, Prozentsatz As Double, wie_oft As Long) As Double
Dim a As Long
Prozentsatz = Prozentsatz / 100
For a = 1 To wie_oft
Wert = Wert - (Wert * Prozentsatz)
Next
xProzent = Wert
End Function



Gruß K.Rola


Bild


Betrifft: AW: brauche Hilfe zum wiederholten Prozentabzug
von: Hans W. Hofmann
Geschrieben am: 26.11.2003 21:38:23

Hallo Excelmaus,

Mathe ist nicht Deine starke Seite ;-)?
x*(1-z)^y
wobei z eine xl-Prozentzahl ist 10% = 0,1


Gruß HW


Bild


Betrifft: AW: Hilfe zum wiederholten Prozentabzug - ohne VBA
von: FP
Geschrieben am: 26.11.2003 21:46:40

Hallo Excelmaus,

Excel Jeanie HTML
Formeln der Tabelle
D2 : =RUNDEN(A2*(1-C2)^B2;2)
D3 : =RUNDEN(A3*(1-C3)^B3;2)
D4 : =RUNDEN(A4*(1-C4)^B4;2)
D5 : =RUNDEN(A5*(1-C5)^B5;2)
D6 : =RUNDEN(A6*(1-C6)^B6;2)
D7 : =RUNDEN(A7*(1-C7)^B7;2)
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

Servus aus dem Salzkammergut
Franz


Bild

Beiträge aus den Excel-Beispielen zum Thema " Blattschutz aufheben - Geschwindigkeitsproblem"