Datumsproblem

Bild

Betrifft: Datumsproblem
von: Gerhard
Geschrieben am: 02.12.2003 17:41:57

Hallo Excelspezis!
Ich stehe vor einem Problem, das ich allein nicht lösen kann.
Ich hab eine relativ aufwendige Tabelle, in der ich in der Datumseingabe einen Strich für den abgelaufenen Monat benötige, damit das Datum ( per Makro) an der richtigen Stelle eingetragen wird.
Jetzt hab ich aber ein Problem mit dem Schaltjahr, weil im Bezug auf den Tag ( im Beispiel "AS6" ) einfach nur die Zahl "304" eingetragen ist.
Beispiel für Monat Oktober
=WENN($A$12>($B$12+$AS$6);"-";"")
A12 ist =HEUTE()
B12 ist 37622 (01.01.2003)
AS6 ist 304 (der 31.10.03), somit bekomme ich für den abgelaufenen Monat den - angezeigt
Wie kann ich das so verbessern, das automatisch der entsprechend letzte Tag eines Monats in eine Zelle ( oder 12 verschiedene Zellen ) eingetragen wird. denn wenn ein Schaltjahr ist stimmt ab Februar die Tabelle nicht mehr.
Kann mir jemand helfen ?
vielen Dank erstmal für Euer Interesse
Gruß Gerhard

Bild


Betrifft: AW: Datumsproblem
von: ooa
Geschrieben am: 02.12.2003 18:01:32

Hallo Gerhard,

probier es mal mit der Funktion MONATSENDE. Die Syntax ist =Monatsende(A1;0), wobei der Parameter Null für den lfd. Monat steht, 1 wäre einen Monat später, 2 ist zwei Monate später usw. Vielleicht hilft dir das weiter.

G.a.BY
Niko


Bild


Betrifft: AW: Datumsproblem
von: RainerW
Geschrieben am: 02.12.2003 18:01:38

Hallo Gerhard,

"... automatisch der entsprechend letzte Tag eines Monats in eine Zelle
eingetragen wird."

mit folgender Formel wird angezeigt, wie viele Tage ein Monat hat
(28, 29 bei Schaltjahr, 30 oder 31 Tage):
=TAG(DATUM(JAHR(A1);MONAT(A1)+1;0))

Gruß Rainer


Bild


Betrifft: AW: Datumsproblem
von: Gerhard
Geschrieben am: 02.12.2003 18:09:24

DANKE Niko und Rainer !!
Ich werde es ausprobieren.
Gruß Gerhard


Bild


Betrifft: AW: Datumsproblem
von: Gerhard
Geschrieben am: 02.12.2003 18:50:26

Hallo Nike! Leider funzt das so nicht es wird Name? angezeigt
Aber trozdem Danke für Deine Mühe !

Gruß Gerhard


Bild


Betrifft: AW: Datumsproblem
von: Gerhard
Geschrieben am: 02.12.2003 18:51:14

Hallo Rainer Deine Formel Passt genau in meine Tabelle
Danke Du hast mir sehr geholfen!!
Gruß Gerhard


Bild


Betrifft: Danke für deine Rückmeldung Gerhard - o.T
von: RainerW
Geschrieben am: 02.12.2003 20:27:37

 


Bild

Beiträge aus den Excel-Beispielen zum Thema " Close-Event der Druckvorschau"